Jump to content
Sign in to follow this  
JustinP526

Can't get updates

Recommended Posts

Still not yet got new laptop, so this is on the old Dell XPS M1330. It's running OpenSUSE 13.2 KDE 64 bit. It's been popping up and error message from the task manager thing where it usually shows available updates. I choose 'yes' for it to accept (then asks for root password, which I put in and press enter), but then it goes into a loop of popping up the same error every 5 minutes.

 

How can I fix this?

post-78219-0-92654600-1478736358_thumb.png

Share this post


Link to post
Share on other sites

open a terminal, su to root and enter this command.

zypper -v up

that will find and install any updates.

 

if you get the same question enter "a" i think if memory serves to always trust that repo.

 

that i believe will update your pc while also fixing the trust relationship with that repo for the next time you have updates and use the gui to install them.

 

:b33r:

Share this post


Link to post
Share on other sites

just means verbose, and is used to show more details of what's happening than just running a command without it.

 

must admit though with zypper i'm not sure what extra details it shows, but it's something i always use where possible because some commands don't show any details at all when run unless you use the verbose flag.

 

:b33r:

Share this post


Link to post
Share on other sites

Now I'm getting errors that update can't connect to medium for almost all repos.

Share this post


Link to post
Share on other sites
nigsy   

Now I'm getting errors that update can't connect to medium for almost all repos.

 

Are you running zypper up from terminal (as root)?

 

Maybe a restart might flush the issue.

 

 

Or....

 

Is it trying to connect to the DVD repo left over from when you installed? Check the repositorys' in YAST and uncheck the 'Enabled ' flag for any that are pointing to your DVD / C:/ drives. Delete them if that stops the issue.

Share this post


Link to post
Share on other sites

Checked all that and it all looks good. Only 1 repo is not working now. It is for emulators.

post-78219-0-84433400-1492210986_thumb.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×