Jump to content
Sign in to follow this  
duanester

Amarok Help (SOLVED)

Recommended Posts

Forced to use VLC backend, by default VLC is backend, nothing works rite, so switched to Gstreamer to have a functional equalizer and analyzer affect display, I cannot get Amarok to play anything, play button is locked.

 

with gstreamer

Amarok Diagnostics

Amarok Version: 2.8.0
KDE Version: 4.14.21
Qt Version: 4.8.7
Phonon Version: 4.9.0
Phonon Backend: GStreamer (4.9.0)
PulseAudio: Yes

Amarok Scripts:
    Amarok Script Console 1.0 (stopped)
Lyricwiki .2 (running)
Free Music Charts 1.6.0 (running)
Librivox.org 1.0 (running)
Cool Streams 1.0 (running)

Amarok Plugins:
    AudioCd Collection (enabled)
DAAP Collection (disabled)
MTP Collection (enabled)
MySQLServer Collection (enabled)
MySQLe Collection (enabled)
UPnP Collection (disabled)
Universal Mass Storage Collection (enabled)
iPod, iPad & iPhone Collection (enabled)
Ampache (disabled)
Jamendo (enabled)
Last.fm (enabled)
MP3 Music Store (enabled)
MP3tunes (disabled)
Magnatune Store (enabled)
Podcast Directory (enabled)
gpodder.net (disabled)


Be back, need to VLC and log out

Edited by duanester

Share this post


Link to post
Share on other sites


Amarok Diagnostics

 

Amarok Version: 2.8.0

KDE Version: 4.14.21

Qt Version: 4.8.7

Phonon Version: 4.9.0

Phonon Backend: VLC (0.9.0)

PulseAudio: No

 

Amarok Scripts:

Amarok Script Console 1.0 (stopped)

Lyricwiki .2 (running)

Free Music Charts 1.6.0 (running)

Librivox.org 1.0 (running)

Cool Streams 1.0 (running)

 

Amarok Plugins:

AudioCd Collection (enabled)

DAAP Collection (disabled)

MTP Collection (enabled)

MySQLServer Collection (enabled)

MySQLe Collection (enabled)

UPnP Collection (disabled)

Universal Mass Storage Collection (enabled)

iPod, iPad & iPhone Collection (enabled)

Ampache (disabled)

Jamendo (enabled)

Last.fm (enabled)

MP3 Music Store (enabled)

MP3tunes (disabled)

Magnatune Store (enabled)

Podcast Directory (enabled)

gpodder.net (disabled)

 

 

 

Share this post


Link to post
Share on other sites

don't think you want to use vlc backend duan, far as i'm aware they stopped supporting it, so whatever the problem is i'd stick with using gstreamer backend.

 

what os are you using? and what if any error message do you get? start amarock in terminal to see it's output that should offer a clue on what the problem is.

 

:b33r:

 

have you installed all needed codecs?

 

try a zypper up and then see if it works after adding the packman repo if you don't already have it, assume your running a version of suse.

Edited by terry1966

Share this post


Link to post
Share on other sites


duane@linux-lei1:~> amarok

Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)

kbuildsycoca4 running...

amarok(6401)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:

libpng warning: iCCP: known incorrect sRGB profile

QWidget::insertAction: Attempt to insert null action

amarok(6401)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:

QWidget::setMinimumSize: (Media Sources dock/BrowserDock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Playlist dock/Playlist::Dock) Negative sizes (0,-1) are not possible

**********************************************************************************************

** AMAROK WAS STARTED IN NORMAL MODE. IF YOU WANT TO SEE DEBUGGING INFORMATION, PLEASE USE: **

** amarok --debug **

**********************************************************************************************

duane@linux-lei1:~> "<?xml version="1.0" encoding="UTF-8" ?>

<lfm status="failed"><error code="6">User not found</error>

</lfm>

"

Calling appendChild() on a null node does nothing.

Could not parse stylesheet of widget 0x2320f00

QWidget::setMinimumSize: (Media Sources dock/BrowserDock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Playlist dock/Playlist::Dock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Playlist dock/Playlist::Dock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Playlist dock/Playlist::Dock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Playlist dock/Playlist::Dock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Playlist dock/Playlist::Dock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Playlist dock/Playlist::Dock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Media Sources dock/BrowserDock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Playlist dock/Playlist::Dock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Media Sources dock/BrowserDock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Media Sources dock/BrowserDock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Playlist dock/Playlist::Dock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Media Sources dock/BrowserDock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Media Sources dock/BrowserDock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Media Sources dock/BrowserDock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Media Sources dock/BrowserDock) Negative sizes (200,-1) are not possible

QWidget::setMinimumSize: (Media Sources dock/BrowserDock) Negative sizes (200,-1) are not possible

** Message: PackageKit: xid = 96469245

** Message: PackageKit: desktop_id = (null)

** Message: PackageKit: Codec nice name: MPEG-1 Layer 3 (MP3) decoder

** Message: PackageKit: ignoring field named parsed

** Message: PackageKit: field is: mpegaudioversion, type: gint

** Message: PackageKit: field is: mpegversion, type: gint

** Message: PackageKit: field is: layer, type: gint

** Message: PackageKit: structure: gstreamer1(decoder-audio/mpeg)(mpegaudioversion=1)(mpegversion=1)(layer=3)()(64bit)

** Message: PackageKit: Did not install codec: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.PackageKit was not provided by any .service files

** Message: PackageKit: xid = 96469245

** Message: PackageKit: desktop_id = (null)

** Message: PackageKit: Codec nice name: MPEG-1 Layer 3 (MP3) decoder

** Message: PackageKit: ignoring field named parsed

** Message: PackageKit: field is: mpegaudioversion, type: gint

** Message: PackageKit: field is: mpegversion, type: gint

** Message: PackageKit: field is: layer, type: gint

** Message: PackageKit: structure: gstreamer1(decoder-audio/mpeg)(mpegaudioversion=1)(mpegversion=1)(layer=3)()(64bit)

** Message: PackageKit: Did not install codec: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.PackageKit was not provided by any .service files

 

 

 

Share this post


Link to post
Share on other sites
PackageKit: structure: gstreamer1(decoder-audio/mpeg)

Terry i cannot believe this, It'll never happen again :facepalm:

 

Thanks for your help, never would have known if i didn't run in Konsole.

 

Stupid codecs :lol:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...