Jump to content
Sign in to follow this  
geneb53

PCMatic will not install

Recommended Posts

I am trying to install PCMatic on a second computer. It has Windows XP Home service pack 3, 32bit version. The install goes almost all the way during setup but stops just before finishing with this popup::

 

C:\Program Files\pcpitstop\pc matic\adblockers\pcmaticadblocker.dll

unable to register the DLL/OCX:RegSvr32failed with error code 0X3

 

Does anyone have any ideas as to how I can get this paid program to install?

 

Share this post


Link to post
Share on other sites

Hello Ykawika, I tried your solution to my problem but I'm sad to say it didn't work. It ran and said it repaired files and that it completed successfully (I guess no harm no foul). But alas, no PCMatic install for me. I have been waiting 6 now going on 7 days to hear anything back from customer support via Ticket # TSL-966-60755 . So far no joy and not one answer from them. I do appreciate your efforts to help solve my problem. Regards; geneb53

Share this post


Link to post
Share on other sites

You're not hearing anything because the email replies from the help desk are getting picked off as spam somewhere along the line. Ticket #TSL-966-60755 has been answered three times since February 27, but it appears that you have not received a single reply.

 

What web browsers are installed on the computer, with version number please.

 

Does the popup message have an option to skip or ignore the message?

Share this post


Link to post
Share on other sites

Hello IntelGuy, thanks for responding to my post regarding "PCMatic will not install" and the perceived issue of no response from tech support on Ticket # TSL-966-60755. I was surprised to learn that I had been sent three answers to my install problem but, hadn't received a single fix via e-mail. I found this a bit curious, so I went looking to my e-mail provider and found that my e-mail was being filtered thru a program called Barracuda|spam firewall. I entered the program and white listed pcpitstop.com, PCMatic.com, and csticket@pitstop.com. As an extra step I went and turned off all scanning and quarantine functions until we can sort out my problem.

I have two browsers on both computers IE8 ( I do not use ) and Mozilla Firefox ver: 44.0.2 as my default... For an e-mail program, I use Outlook on my primary computer and outlook express on the secondary computer.

When I try to install PCMatic on my secondary computer I get this pop up::C:\Program Files\pcpitstop\pc matic\adblockers\pcmaticadblocker.dll
unable to register the DLL/OCX:RegSvr32failed with exit code 0x3

I do get options such as Abort, Retry, Ignore (not recommended)

I hope this helps in your diagnosis. regards geneb

Share this post


Link to post
Share on other sites

The error is generic, our installer puts that file on the computer then uses regsvr32 to register the DLL. The 0x3 error code means the path is not found. What I am assuming is happening is it's possible the installer is not elevated, and cannot register the DLL because it is not an admin.

Make sure that you are both installing and running PC Matic from an administrator account. You can right-click on the icon(s) and select 'Run as administrator'.

To install PC Matic as administrator. right-click on the link below and select "Save target as..." then save the file above to your desktop, then right-click on the saved file and select, "Run as ..." and select an admin account to start the installer.

 

http://pcmatic.com/download

Share this post


Link to post
Share on other sites

Hi IntelGuy,I'm logged on as PREFERRE-810DB6\user this has admin status as I can change the system clock with no problems. I did download and saved target to my desktop. When I right click the icon it gives me a choice to use the preferre-810DB6\user or to use anotheruser name that does not show up in the box..IE. the other user name and password are blank... please advise thanks.

Share this post


Link to post
Share on other sites

As long as PREFERRE-810DB6\user has admin privileges go ahead and use that account. Let us know how that goes.

 

If PC Matic installs go to Control panel>Add/Remove Programs and verify that the PC Matic version there is 1.1.0.67.

Share this post


Link to post
Share on other sites

Hi IntelGuy,I'm logged on as PREFERRE-810DB6\user this has admin status

 

SOrry to jump in....

 

The user might be set up with as Administrator; but there is another system admin privalledge (refered to as elevated admin) that you only get by right clicking on the icon and selecting "run as admin"

Share this post


Link to post
Share on other sites

Hello IntelGuy, I right clicked on the PCMatic setup icon and selected PREFERRE-810DB6\user, and ran the download. Sadly it did the very same thing( same error code with the same options).I looked everywhere in the box that was presented after right clicking the install icon but, alas no "Run as admin" was to be found; sorry Nigsy. I found only "run as current user" or an option to use " the following user" which has no name or passcode.

Is it possible to set up an administrator account with all privliges and use that ? Or barring that would it be possible to manually register the pcmaticadblocker.DLL

thanks geneb53

Share this post


Link to post
Share on other sites

If you go to C:\Program Files\PC Pitstop\PC Matic\AdBlockers is the PCMaticAdBlocker.dll in that folder? If yes, you can open a command prompt and try using RegSvr32 to manually register the DLL.

Share this post


Link to post
Share on other sites

My bad; didn't see you were running XP.

 

Admin is Admin in XP, the concept of elevated rights was introduced in Vista.

 

If Intelguys manual fix doesn't work you could try opening a command prompt (logged in as yourself, admin); drag the executable into the cmd window; the whole path should copy into the window.....press enter.

Share this post


Link to post
Share on other sites

Hello intelGuy and his Lordship Sir Nigsy, Sorry for the time lapse, I had chores to complete around Home and hearth.In regards to your last question, when I go into windows explorer to my; C:\Program Files\PC Pitstop\PC Matic I find nothing but an icon that looks like a shortcut to PCMatic, nothing else...Now as an observation when you Abort the setup program it rolls back any installed progress.

How do you think we should proceed? Regards geneb53

Share this post


Link to post
Share on other sites

Hello IntelGuy,I tried to install PCMatic from the link you provided. Sadly, it did the same thing with the same error code. However before pressing the option to "Abort" I went to C:\Program Files\PC Pitstop\PC Matic\AdBlockers and there was a file called PCMaticAdBlocker.dll... I would have tried to install via command prompt and try using RegSvr32 to manually register the DLL. But I have never done that before (mess with registry) but I will be willing to venture into that area if supported with more detailed instructions.After I used the option to roll back the install, I went back in to C:\Program Files\PC Pitstop\PC Matic\AdBlockers and found nothing there. The PCMaticAdBlocker.dll was gone..

As a side thought, do you think my registry might be flawed? and if so, is there a registry repair tool? Thanking you for your help; geneb53

Share this post


Link to post
Share on other sites

Hello IntelGuy, Yes I have tried using the ignore button and at first it looks like the program installed...BUT, later on when you run a scan it will find registry errors ( in my case 106 of them ) when auto fix is selected, it says it fixed the registry errors. However, If you run another scan it will find the same number of registry errors again, If you apply auto fix and re-scan yet again , the errors rear there ugly head again.

You can do this Ad Nauseaum. It also seemed to act strangely when a PCMatic program update was applied, ie: PCMatic just disappeared, the only thing that was left was the green SuperShield icon down by the clock . I was mystified by these events and tried to reinstall PCMatic again using the latest version of PCMatic software but, no joy. That's when I relented and filled out a customer service ticket that I mistakenly thought was being ignored. In desperation I joined the PCMatic Forum in order to get some help with this problem. And so, we have come full circle. I do appreciate all your efforts to help me get this program installed and await further instructions. Regards; geneb53

Share this post


Link to post
Share on other sites

Greeting Sir Nigsy, I have used ccleaner before. I downloaded the link you provided and ran the program. I then attempted to install PCMatic.. It did not install yet again, with the now familiar " unable to register the dll/ocx: Regsvr32 failed with exit code 0x3 ". I then opted to push the " ignore" button so as to keep the PCMaticAdBlocker.dll from rolling back to pre install conditions. I then opened a "cmd" window and typed.. Regsvr32 C:\ProgramFiles\PCPitstop\PCMatic\AdBlockers\PCMaticAdBlocker.dll and pressed enter.

The results were disappointing, I received an error 'Load Library (Regsvr32 C:\ProgramFiles\PCPitstop\PCMatic\AdBlockers\PCMaticAdBlocker.dll ) failed - the specified module could not be found.' Now I'm wondering if I need to add the PCMaticAdBlocker.dll binary file to my windows/system32 folder. I mentioned to Intel guy that I needed guidance to enter the registry arena, I await that reply. My uneducated guess is that the binary .dll file and/or files need to be copied into the system32 folder and then registered via the regsvr32 command line. I await your valued advise as to how to proceed. Regards geneb53

Share this post


Link to post
Share on other sites

I have the same problem but I'm running windows 7/32 and running as admin doesn't help nor does the link to new installer. I'm not as experienced as GeneB nor do I have the patience. I suppose I should mention that this was an XP with clean 7/32 install from CD. IE is the one on the CD

Share this post


Link to post
Share on other sites

Hi David,

 

Do you have Service Pack 3 installed on the XP installation?

 

This is required.

 

http://www.majorgeeks.com/files/details/microsoft_windows_xp_service_pack_3.html

 

Once SP3 is installed, grab any and all updates for that OS as well.

 

Then give the installation of PC Matic another try.

 

:) Y

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...