Jump to content
Sign in to follow this  
M1918A1

No internet windows 7 (Resolved)

Recommended Posts

I have been working on a Dell Inspiron 570 with Win 7 Home Premium 64 bit for the last two weeks. The only problem it has is that it will not connect to the internet. I have found lists of several fixes for this online and have tried all of the ones that I understood. None of them worked. The system shows that the ethernet cable is unplugged. Today, I put in a new pci ethernet card (Win7 64bit compatable) and installed the drivers. Like the onbord ethernet connection, it shows that the card is running properly in device manager. The computer shows that the ethernet cable is still unplugged. I know the cable is good and the router is working properly because I plugged in an XP computer to work on it a few days ago and the internet worked fine on it. This is the first time I have worked with Win7, so I am not very familiar with it.

The guy that owns the computer told me that the internet stopped working several months ago. He suspected that an improperly functioning Mcafee antivirus may have been the problem. That was the first thing i tried. When I attempted to start Mcafee, all I got was a blank white box that popped up. The same thing happened when I tried to uninstall it through add/remove programs. What I did was go through and delete all of the mcafee files everywhere I could find them and went through the registry and deleted every reference to Mcafee....That took some time. Removing all the Mcafee references didn't help.

Apparently, from all of the fixes I found (and tried) online, this is a fairly common problem with Win7.

 

Anybody have an idea how to fix it?

Share this post


Link to post
Share on other sites

Tried the first video a week ago...back then I got 3 packets sent, 0 received'

This time I got "request could not find host"

 

tried the second video-it was hard to follow because I had to run magnification to 400% to see what he was doing-did everything except click on "refresh" because I could not find that option where the cursor was pointing. Still shows no internet connection.

Share this post


Link to post
Share on other sites

look on the ethernet port where the cable is plugged in. there are two lights. are they lit up? if so, what are the colors and are either of them blinking?

 

if you have lights you have a good connection to the router and hardware can pretty much be ruled out. if no light then you likely have a hardware issue (the nic, cable, or router).

 

if you have lights boot into safe mode with networking. do you get internet there?

Share this post


Link to post
Share on other sites

The lights are yellow. With the onboard ethernet there is a solid light and blinking when I try to get on the internet. The add on card shows yellow light but it does not blink.

 

No internet in safe mode.

 

The router (Windstream) works fine. Every other computer I hook up at that port gets internet.

Share this post


Link to post
Share on other sites

I'd say that one solid yellow and one blinking yellow light where the ethernet cable plugs in means you have transfer from that point. Something must be blocking it...firewall?, antivirus???

 

 

 

 

:geezer:

Share this post


Link to post
Share on other sites

With the computer connected to the router, Go to Start and type: cmd


At the top you'll see the command console icon.


Right click it and choose: "Run as Administrator"


At the prompt, type: ipconfig /all


Hit the enter key on the keyboard



Find the ethernet connection listed for your ethernet adapter and let us know what is listed for:


Physical Address


DHCP Enabled


IPv4 Address


Default Gateway



:) Y


Share this post


Link to post
Share on other sites

Onboard ethernet



Physical Address B8-AC-6F-BD-0F-18


DHCP Enabled No


IPv4 Address 192.168.137.1


Default Gateway None showing




Add on ethernet card:



Physical Address 00-0A-CD-26-83-FF


DHCP Enabled Yes


IPv4 Address 192.168.254.6


Default Gateway 192.168.254.254




Another computer on the same router has an ip address of 192.168.254.2. Default gateway etc same as add on card


Share this post


Link to post
Share on other sites

 

Another computer on the same router has an ip address of 192.168.254.2. Default gateway etc same as add on card

 

 

This computer is connecting properly to the internet with a Default Gateway of 192.168.254.254?

Is DHCP Enabled on that computer with the 192.168.254.2 address?

 

:) Y

Share this post


Link to post
Share on other sites

Yes, it is enabled. That computer (the one I am using to reply with) is XP pro. I have, in the past 2 weeks, switched cables between the 2 computers and the XP computer works on either ip address but the Win7 computer won't work on either......or the other two router ports that have XP Pro computers attached to them. Weird, isn't it?

Share this post


Link to post
Share on other sites

Since the onboard Ethernet adapter has DHCP turned off, set the IP Address and the Default Gateway to static entries.

Try these:

IPv4 Address 192.168.254.8

Default Gateway 192.168.254.254

Here's how:

Click Start>Control Panel, under Network and Internet

Click on: View Network Status and Tasks

On the upper left, Click on: Change Adapter settings

Right click your Local Area Connection icon corresponding to your ethernet adapter and choose Properties

Now double click Internet Protocol Version4 (TCP/IPv4)

Put a dot in "Use the following Address"

Enter these values:

IP Address: 192.168.254.8

Subnet Mask: 255.255.255.0

Default Gateway: 192.168.254.254

Put a dot next to: Use the following DNS server addresses:

Enter this value:

Preferred DNS server: 192.168.254.254

~ leave the alternate DNS address blank.

Okay your way out, click apply where needed and then reboot.

If it's still not working, power-cycle the router and modem and then try again.

:) Y

Share this post


Link to post
Share on other sites

Did both.........Ended up with a yellow triangle with an exclamation point between "computer" and "home network" that wasn't there before. Changed the last number on the ip to "6" like it usually is and got no change. Switched back to the 8 and again, no change.

 

I tried plugging it into the add on card (default ipv4 192.168.254.6) and the yellow triangle goes away, but the red X between home network and internet is still there.

Share this post


Link to post
Share on other sites

The yellow triangle with exclamation point is typically an indicator of a driver error.

 

Uninstall and then reinstall the drivers for your "onboard" ethernet controller and make sure that it is enabled in the BIOS.

Once done, go back to the Static addresses and try it again.

 

If this doesn't work, re-enable DHCP and automate the DNS server to see if the router will do the configuration for you.

 

:) Y

Share this post


Link to post
Share on other sites

Setting the ip etc. back to automatic finally got rid of the triangle between computer and home network. Still have the red X between home network and internet.

 

I ran ipconfig afterward and it showed dhcp enabled and an ip address of 192.168.254.4

Share this post


Link to post
Share on other sites

Setting the ip etc. back to automatic finally got rid of the triangle between computer and home network. Still have the red X between home network and internet.

 

I ran ipconfig afterward and it showed dhcp enabled and an ip address of 192.168.254.4

 

Is the correct Gateway showing: 192.168.254.254 ?

 

Something else to investigate, is whether IE has a proxy set.

Go to Start>Control Panel>Network and Internet>Internet Options

Click the Connections Tab, then click LAN Settings

Uncheck everything there.

Apply and OK your way out.

 

:) Y

Share this post


Link to post
Share on other sites

Yes, the gateway is 192.168.254.254

 

I unchecked the box in lan settings and rebooted but nothing changed.....still have the red X and no internet

Share this post


Link to post
Share on other sites

Let's try a little experiment and try Safe Mode with Networking to see if anything changes.

 

Reboot, Tap the F8 key, use your keyboard arrow keys to select Safe Mode with Networking, hit Enter.

 

:) Y

Share this post


Link to post
Share on other sites

safe mode didn't work

 

 

Also, whwn I am in the command promp and click ipconfig /all, where it shows "media state" it is listed as disconnected. It has done this every time i have run the ipconfig for the past 2 weeks. The cable is always plugged in, but it always says media disconnected. Dosen't matter which ethernet plug in I use and changing the cable doesn't make a difference. I probably should have mentioned this earlier but I just watched a video that said "media disconnected" means a cable is unplugged.

Share this post


Link to post
Share on other sites

Let's see if stopping and starting key network services has an influence.

 

Go to Start

Type: services.msc

Enter

Scroll down and find:

 

Network List Service (Manual)

Network Location Awareness (Automatic)

 

One at a time, double click the entry, then click Stop.

Then Re-Start the Service.

 

:) Y

Share this post


Link to post
Share on other sites

Stubborn buggar!

 

Do you have a Windows 7 disk?

If not, you can download and burn one from an Iso file here: http://www.w7forums.com/threads/official-windows-7-sp1-iso-image-downloads.12325/page-2#post-124821

 

Once you have a disk ready, run sfc /scannow from an elevated command prompt to repair or replace any corrupted files that may be causing this craziness.

 

Sure is a tough one to get going again. :mrsgreen:

 

:) Y

Share this post


Link to post
Share on other sites

Took hours to download the image. This is what I got:

 

"Resource protection did not find any integrity violations"

 

Still no internet

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...