Jump to content
Sign in to follow this  
pickster

Change main drive from F: back to C: after reloading Xp.

Recommended Posts

I replaced my hard drive with a bigger used hard drive using Windows xp after erasing the data. The problem is that now drive F: has the main storage 149 GB and drive C: says 500 mb which is labeld as primary drive. How do I get my main hard drive back to C: in stead of F: I can't restore my back up file for some reason since it was originally saved from the C: drive. Do I need to reinstall xp and put it on C:? When I go to disk management , it won't let me chane the letter of the F drive back to C:

 

Thanks

Share this post


Link to post
Share on other sites

You haven't provided any information about the current hardware configuration, so I'll make some guesses. Either (1) the smaller and larger hard disks are both installed; or (2) only the larger disk is present. In addition, (3) a memory card reader may be connected, and (4) one or more discs contain multiple partitions and logical drives.

 

If present, disconnect the memory card reader or disable it in the Device Manager, Open the Disk Management utility.

 

In the lower pane, how many disks are listed? Which is Disk 0 and Disk 1?

 

What drive letters are associated with each hard disk? Which drive letters are reported as Active, System, and Boot?

Share this post


Link to post
Share on other sites

I only have 1 hard drive installed 160 GB WD. When I open disk management it says I only have 1 hard drive volume F:

 

disk 0

F: 149.04 GB NTFS

Basic

149.04 GB

 

disk 1

removable C:

No media

Share this post


Link to post
Share on other sites

That can happen if your pc has a sd card reader, disconnect it before you install windows

Share this post


Link to post
Share on other sites

Where do you find the SD card reader? I don't see it under device manager. The only thing I replaced was the hard drive and I had my external hard drive plugged in to back up my computer . I then unplugged it before I ran the xp disk.

Share this post


Link to post
Share on other sites

some specs about your pc would help.

brand name? model number? service tag if it has one?

did you just yank out the usb external drive or use windows to eject it first before you pulled it out?

Share this post


Link to post
Share on other sites

Dell 4600,no service tag. I'm putting in a used WD 160 GB hard drive to replace my old seagate 38 GB hard drive. I turned off the external hard drive G: and unplugged it. I tried to reinstall windows and it only gives me F: as a choice to install it. The bad thing is when I try to reinstall the drivers, they're all based on using drive C: not F:. So I would like to put the main drive as C: I erased the whole hard drive before I installed the fresh XP set up.

Share this post


Link to post
Share on other sites

looks like you could have have two partitions on that drive.

when you installed windows during the partition management part of the install did you see more than one partition and did you delete both partitions and format the entire drive?

What version of windows are we dealing with?

 

 

 

 

.

Edited by Joe C

Share this post


Link to post
Share on other sites

When I originally loaded it. C: drive had around 500 MB. F: had 149 GB. I erased the whole hard drive with KILLDISK. before I installed xp pro. I didn't think C: drive would hold it with 500 MB. Why does Drive C: say removeable disk under disk management?

Share this post


Link to post
Share on other sites

Usually you see something like that when you have a sd memory card reader, or a floppy disk in the floppy drive. How many partitions did you see in the partition management when installing windows?

 

 

 

 

 

 

.

Edited by Joe C

Share this post


Link to post
Share on other sites

I only have 1 hard drive volume F:

 

disk 0

F:

 

disk 1

removable C:

 

Since Disk Management shows two physical disks, each as only one logical drive, let's just swap the drive letters.

To do this, log on to any account with administrator's rights (if you wish, start in Safe Mode and use the Administrator account). Click Start and Run, type Regedit and click OK to open the Registry Editor. If any registry keys are already open, press cursor-left (the left arrow key) until the tree in the left pane has collapsed, then press cursor-right.

Open the following registry key.

HKEY_LOCAL_MACHINESYSTEMMountedDevices

In the right pane, right-click DosDevicesC: and click Rename. Edit the name to read DosDevicesZ: and click OK.

Right-click DosDevicesF: and click Rename. Edit the name to read DosDevicesC: and click OK.

Right-click DosDevicesZ: and click Rename. Edit the name to read DosDevicesF: and click OK.

 

Restart the computer normally.

Share this post


Link to post
Share on other sites

How do I go back to change the settings as they were before? The computer won't boot up now, I want to see if I done it correctly. It looks like it still wants to have F as the main drive. Maybe F doesn't have the start up procedure.

 

Thanks

Share this post


Link to post
Share on other sites

The computer won't boot up now ... Maybe F doesn't have the start up procedure.

If the boot files ("startup procedure") are not on the drive (previously F), then they must be located on another drive. BUT — according to your minimal information, there are NO other drives.

 

What is the exact and complete error message? Are there any other changes, however minor or apparently unrelated, that you've made to the system?

Edited by TomGL2

Share this post


Link to post
Share on other sites
My feeling at this point is that you should simply reinstall XP. First, however, you must unplug (or disable in BIOS) memory card readers, all external devices (including flash and external USB or Firewire drives), plus cameras, printers, and other harrdware; and have only one hard disk and one CD/DVD drive connected. Edited by TomGL2

Share this post


Link to post
Share on other sites

Tom may be right about just going with a re-install, but since the C drive has been altered, perhaps writing a Master Boot Record to it will resolve the issue.

 

http://www.ykawika.com/noboot.html

 

You can skip step 5 as it is redundant.......... I keep forgetting to edit that out. :)

 

Don't see it hurting any to try.

 

:) Y

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...