Jump to content
Sign in to follow this  
Champion_Munch

Lags On Post After Installed New Dvd Drive

Recommended Posts

Hey pit-goers! How goes it? I've just installed a new SATA DVD drive and now often the computer lags at the POST screen and I can't access the BIOS - although after rebooting a few times eventually it will get through, and Windows XP recognises the drive fine and I can use it perfectly. I've tried changing a few settings in the BIOS (when I've been able to get in) but I still end up with the same problem. Any ideas?

 

I've currently got 2xIDE HDDs which are on the same cable. My MOBO is K8X250GB-Pro.

 

Cheers :mrgreen:

Share this post


Link to post
Share on other sites

Some of the early SATA controllers didn't work well with CD or DVD drives.

Check that the sata cable is plugged in good.You may need a new controller card.

Share this post


Link to post
Share on other sites

Can you confirm that the SATA Cable is plugged correctly in both your CD/DVD Drive and the Motherboard? Some SATA Cables cannot be plugged-in randomly; there are plugs specially for your motherboard and the peripheral you wish to connect.

 

generics wildcard

Edited by johnkon32

Share this post


Link to post
Share on other sites

Hey guys,

 

I tried swapping the cable around, tried a different cable, tried both SATA mobo ports... still the same problem. Sometimes I get this message after POST (but it won't boot windows still):

 

NVIDEA RAID IDE BIOS 1.13a

Copyright © 2003 NVIDEA Corp.

Detecting array...

 

Any ideas?

 

Cheers :mrgreen:

Share this post


Link to post
Share on other sites

Hmmm, are you running RAID? Appears to be looking for a RAID array...if no RAID, next time in BIOS be certain that your controller is set to IDE. Looks like you could be due for a system upgrade too, Champ...

 

 

 

 

:geezer:

Share this post


Link to post
Share on other sites

Hey caintry boy,

 

Nah I'm not running RAID. There's a setting to enable RAID in the BIOS but I have that set to disabled. I couldn't find anything else in BIOS that looked like it might help either unfortunately.

 

And yeah, this is my first computer and it's now... 6 and a half years old. Still running strong. :mrgreen: Well, except for this hiccup...

 

Cheers :mrgreen:

Edited by Champion_Munch

Share this post


Link to post
Share on other sites

how does it boot without the drive connected?

If it boots fine w/o the drive connected, then the drive itself may be wanky. does it boot o.k. with the old drive connected?

Share this post


Link to post
Share on other sites

Hey Joe,

 

It boots fine without the drive connected. The old DVD drive has been disposed of, but it was an IDE. This is the first SATA drive I've tried to connect with this computer.

 

There's no problems with using the drive, once I log into Windows, it's just the messy part at the POST holdup.

 

Cheers :mrgreen:

Share this post


Link to post
Share on other sites

It might be looking to boot to the sata device first. Check your bios for IDE/Sata and set it for IDE, try disabling any raid configs that might be in there too. Make your hard drive the first device in the boot order (same as CB stated)

 

Can you give us the specs of the mobo? Brand, model and version number might help, we can check the boards manual to see if something is being missed.

 

 

 

.

Edited by Joe C

Share this post


Link to post
Share on other sites

Hey Joe,

 

I just popped into the BIOS - seems to have reset itself for whatever reason (default settings/time) but the hard drive is set as first boot device, and the only RAID setting I can see is (and was) disabled. Mobo is: K8X250GB-Pro

 

Cheers :mrgreen:

Share this post


Link to post
Share on other sites

Really older board but look in BIOS for a setting that sets a certain amount of time (i.e. "seconds") for the system to look for *boot media*...if you find it reduce the amount of time allotted...

 

 

 

 

:geezer:

Share this post


Link to post
Share on other sites

I checked the Albatron web site and the manual for your board's bios settings does not exist, There is a manual, but it has nothing on the bios settings, except the manual mentions something about the nvidia firewall, disable it if you see any settings for it.

ftp://ftp.albatron.c..._Pro_EM_N1+.pdf

Make sure you have the jumper on the back set to master or cable select (try master first) if that's the only drive and it's on the very end of the data cable. Often, when you look in the bios it will tell you the ide master/slave configuration that it is set for. It should say ide1 or ide 2 and master, your hard drive should be ide 0 or ide 1 and master if that is the only drive on it's cable

You best option might be is to get another drive (wally world Wall-mart or local pc shop) and try another drive. If it works return the bad one, if that does not work, return the one you used to check it with.

 

 

 

.

Edited by Joe C

Share this post


Link to post
Share on other sites

Hey Joe,

 

I couldn't find any settings for the NVIDEA firewall. My two HDDs are set as IDE Channel 0 Master and IDE Channel 0 Slave, and the SATA drive is under IDE Channel 2 Master (or IDE Channel 3 Master if I chose the other SATA port). Not really sure what you mean about setting the jumper on the drive, I thought that was only IDE drives you needed to configure jumper settings?

 

Also everytime I reboot now the system time/date gets reset.

 

I'll see if I can get the drive to work in any of the other computers here, and failing that I'll have to go buy another one and check it out, as you say.

 

Cheers :mrgreen:

Share this post


Link to post
Share on other sites

my bad... I thought you had an ide drive, but yes. try it in another pc and if it hangs the boot up then it's most likely that drive.

you need a new cmos battery if your losing your time and date. It is a #2032 battery and will cost a few bucks, at any place they sell batteries. Do you see the dvd drive listed in the bios when you go in to it?

I honestly didn't think your board had the nvidia firewall but they did put that on some boards, and your manual did make mention of it. I have no idea what's in the bios for that board so a check for it didn't hurt, it was very flaky and they do not do that any more that I know of.

 

 

 

 

.

Edited by Joe C

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...