Jump to content
Sign in to follow this  
colman69

Pc Matic Error Messages

Recommended Posts

Hi,

 

I just renewed my subscription and installed PC Matic on my new Win7 x 64 PC but I keep getting the following error messages when it starts up:

 

Registry: Unable to open StdRegProv,

The Specified Module cannot be found.

 

I click OK and then I get:

 

RegistryReadError :- 2146823821

'This.SRP.Methods_'is null or not an object

GetStringValue hive = 'HKLM' key= 'software\FreeDownloadManager.org\FreeDownloadManager'=path

 

I click OK then login and get the following error messages:

 

Registry: Read error: -2146823281

'this.SRP.Methods_' is null or not an object

GetStringValue hive='HKLM' key= 'Software\PCPitstop\Nirvana'

name='nitroPrompt'

 

Click OK then:

 

Registry: Write error: -2146823281

'this.SRP.Methods_' is null or not an object

SetStringValue hive='HKLM' key='Software\PCPitstop\Nirvana'

name='nitroPrompt' value='true'

 

and then....

 

 

Registry: Unable to open StdRegProv,

The Specified Module cannot be found

 

After all that it works until the software updates, it downloads them and goes to extract and does nothing else.

 

I have done the registry repair you suggest in another post on forum but no joy.

I have uninstalled it and reinstalled (as admin) and run it (as admin) but still get the messages....

 

Is there any other suggestions?

Thank you

Share this post


Link to post
Share on other sites

:wp:

 

In order to further troubleshoot this issue, please click the link below to download the diagnostic tool:

 

http://www.fileden.com/files/2008/3/27/1839616//fso-reg-test.zip

 

Once you have the file downloaded, right-click on the downloaded file and select "Extract all" to unzip the file.

 

From the unzipped folder, double click on fsoreg.exe to run the tool. A window should open on the screen with the message:

 

cache: 1 (or 0)

c isready: true (or false)

 

If there is an error message instead, then REG or FSO is broken on that system. This is not a problem with PC Matic but rather with the Windows installation. To resolve the error message please follow these steps:

 

1) Run the Windows registry repair tool from the link below:

 

http://files.pcpitstop.com/support/Repair-ActiveX.cmd

 

If you are using Vista, Windows 7, or a 64 bit operating system, first save the file above to your desktop, then right-click on the saved file and select, "Run as administrator".

 

When you run the tool you should see a command window open and be able to watch the tool's progress. The tool may appear to 'hang' once or twice, but if you wait the tool should complete.

 

 

2) If the repair tool does not fix the problem, another common problem is WMI corruption. To check for this:

 

* Right-click the My Computer icon and select Manage.

* Open the "Services and Applications" tree.

* Right-click the "WMI Control" item and select Properties.

 

In the dialog that appears, you should see this message:

 

Successfully connected to:

 

If you see error messages, try the steps recommended on this page to rebuild the WMI Repository:

 

http://windowsxp.mvps.org/repairwmi.htm

 

Or the steps from here to repair permissions:

 

http://8help.osu.edu/3618.html

 

 

 

If the issue is still not resolved, please open a ticket at our help desk so that we can get some more information.

 

You can open a ticket from here:

 

http://www.pcpitstop.com/store/service.asp

Share this post


Link to post
Share on other sites

Hi again,

 

I am pleased to report the problem has been resolved Posted Image

 

With your refrence to W7 installation problem I ran sfc /scannow in cmd prompt (run as admin) and it found several errors which it repaired.

I had to uninstall and reinstall PCMatic as it reported that the software was corrupt and now all is working.

One more thing, the steps in the link http://8help.osu.edu/3618.html can only be done if you have Windows 7 Professional or Ultimate not Windows 7 Starter, Home Basic, and Home Premium editions.

Thanks again for your help Posted Image

Share this post


Link to post
Share on other sites

I have installed PC matic 3 days ago, it was running fine, so i have paid for full version. Today i was trying to start the program and all i get is:

Registry read error: -2146823281

Unable to get value of the property 'Methods_': object is null or undefined

GetDWORDValue hive='HKLM' key='SoftwarePCPitstopPC MaticRT'

name='Active'

 

Please help!

And for the record I've tried that method you have wrote above and it doesn't work. Any other advice? Thanks

 

EDIT

Problem solved.

 

Had to simply right-click on the PC Matic icon and choose troubleshooting compatibility -> try recommended setting -> wait -> if fixed save settings. -> done :woot:

Edited by Zibi Majewski

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...