Jump to content
Sign in to follow this  
Iconoclast

Trying To Setup Linksys Router Internet Connection

Recommended Posts

Hi guys, here's my current situation:

 

I've got a Linksys wireless router (WRT310N) and I just moved from my apartment where I went to school to a room where I live at my new job (I work at a camp). I'm trying to setup my router so that I can broadcast a wireless signal in my building, but for the life of me I can't seem to get it working. Here's the current setup:

 

The internet in my room comes in via Ethernet cable through the wall; I'm not sure where it goes beyond that (whether it's to a switch or another router, etc.) but basically I only have access to this one single Ethernet line. When I connect this Ethernet cable directly to my PC, the internet says I'm connected to "Connection Name" and that I have Internet Access.

 

Here's what I'm trying to do (and what I've been trying to do): connect the Ethernet cable in my room to the modem port on my router (the one for the incoming internet line) and then connect my PC to my router with another Ethernet cable through one of the 4 ports. But when I do this, it connects me to the router, but it says I don't have any Internet Access.

 

I figured it was something to do with my connection settings in the router so I went to the Admin Panel and tried to change the Internet Connection Type but I still haven't had any luck.

 

When I was at school, my router was set to use a PPPoE connection because it needed a username/password connection to my ISP...but here since the internet works directly through my Ethernet cable, I figured PPPoE wouldn't really apply. I tried setting it to "Automatic Configuration - DHCP" but again, it said I had no Internet Access. And when I try to set it to a Static IP Address, it gives me this message when I try to save the settings: "The router IP address equals to the subnet address. Please correct it."

 

Can anyone help me figure out how to setup my router so that I can get my internet to work through it? Any help is greatly appreciated! :)

Share this post


Link to post
Share on other sites

I tried their live chat support but she said that because my router isn't still under warranty (I bought it several years ago), I'm not eligible for technical support. Naturally this led me into a rather heated discussion about the basics of the importance of customer relationships, as well as the costs of a lost customer vs the costs of attaining new ones, blah blah blah.

 

Anyways, end of story, that got me nowhere. Can anyone else help?

Share this post


Link to post
Share on other sites

Two things:

 

1. you need the full setting from your ISP, ie ppoe, password, mtu settin etc. Make sure the modem is set up correctley with this first. Without you will not get to the internet.

 

BUT

 

2. The incoming internet cable you are using probably already comes via a router (hence when you connect the cable you have internet). You do not need another modem but a wireless router:

 

Wireless Router

 

Then connect your pc to this, either by cable (If it has the ports) or get a wireless card for your pc.

Share this post


Link to post
Share on other sites

Try connecting internet cable to one of the ethernet ports on router. You may need to disable the modem on router and also DHCP as well.

Share this post


Link to post
Share on other sites

Try connecting internet cable to one of the ethernet ports on router. You may need to disable the modem on router and also DHCP as well.

 

What do you mean? If I connect my Ethernet cable that the internet's coming in on to one of the 4 ethernet ports on the router then there won't be any sort of connectivity...and how would I disable the "modem on router" and DHCP?

Share this post


Link to post
Share on other sites

My bad.... :blushing: I should have told you to click where it says downloads and then to select your hardware version, and from that there's a small link right below that says "Download". EasyLinkAdvisor will get you going, I've used it many times.....

 

 

 

 

:geezer:

Share this post


Link to post
Share on other sites

What do you mean? If I connect my Ethernet cable that the internet's coming in on to one of the 4 ethernet ports on the router then there won't be any sort of connectivity...and how would I disable the "modem on router" and DHCP?

 

I might be wrong but on your model you cant switch off the modem.

 

See if you can borrow a wireless router from someone, plug the ethernet cable from the wall into this, another cable from the router to your pc, that should do it.

Share this post


Link to post
Share on other sites

No I can't access the modem...I only have access to the one Ethernet cable that comes into my room with the internet on it.

 

No one else here has any sort of computer equipment, either :/

Share this post


Link to post
Share on other sites

Since you get Internet access just by plugging in the cable to the computer, without a password or any other settings, automatic settings obviously can work.  In that configuration, click Start and Run, type CMD and click OK.  Type IPCONFIG /ALL and press Enter.  What are the IP address, subnet mask, default gateway, and DNS server?

Share this post


Link to post
Share on other sites

When my PC is connected directly to the Ethernet cable, it shows this:

IP: 192.168.1.102 (preferred)

Subnet: 255.255.255.0

Gateway: 192.168.1.1

DNS: 209.91.128.10 / 209.91.128.11

 

When it's connected through the router, it shows this:

IP: 192.168.1.100 (preferred)

Subnet: 255.255.255.0

Gateway: 192.168.1.1

DNS: 209.91.128.10 / 209.91.128.11

 

Does this help at all?

Share this post


Link to post
Share on other sites

When my PC is connected directly to the Ethernet cable, it shows this:

IP: 192.168.1.102 (preferred)

Subnet: 255.255.255.0

Gateway: 192.168.1.1

DNS: 209.91.128.10 / 209.91.128.11

 

When it's connected through the router, it shows this:

IP: 192.168.1.100 (preferred)

Subnet: 255.255.255.0

Gateway: 192.168.1.1

DNS: 209.91.128.10 / 209.91.128.11

I see that both routers have assigned IP addresses in the same range, and this may have some bearing on the problem.  There are a couple of things you can try.

 

In the WRT310N's configuration, disable DHCP.  The setting is under Advanced Contiguration / Network Settings.  Also disable network address translation (NAT), under Setup / Advanced Routing.

 

Another option would be to configure the router to assign addresses in a different range.  I'm not sure that the WRT310N allows this, but you can check.

Share this post


Link to post
Share on other sites

More on my suggestion Iconoclast. The "internet link through wall" via ethernet works when connected directly to you PC's ethernet card; therefore it is not a modem type signal and can be shared via the router's ethernet ports. To do this it must be plugged into one of the 4 ethernet ports on router to share it.

There are 4 ports on router, connect your PC to port 1 and "internet link through wall" to port 2 and see what happens. Since you know how to access router setup, you may have to disable DHCP as well.

Share this post


Link to post
Share on other sites

More on my suggestion Iconoclast. The "internet link through wall" via ethernet works when connected directly to you PC's ethernet card; therefore it is not a modem type signal and can be shared via the router's ethernet ports. To do this it must be plugged into one of the 4 ethernet ports on router to share it.

There are 4 ports on router, connect your PC to port 1 and "internet link through wall" to port 2 and see what happens. Since you know how to access router setup, you may have to disable DHCP as well.

 

Okay, I will try plugging it into one of the normal ports. Also, in case I DO need to, how would I go about disabling DHCP in my router admin? Thanks again!

Share this post


Link to post
Share on other sites

Okay, I will try plugging it into one of the normal ports. Also, in case I DO need to, how would I go about disabling DHCP in my router admin? Thanks again!

 

 

On the basic setup screen, there should be your DHCP options, near the bottom, set this to Disable.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...