Jump to content
Sign in to follow this  
AFB

Error code 1601. How to solve it.

Recommended Posts

Hi.anyone had this error code windows installer 1601. It suddenly appeared out of the blue.

 

How do I solve the problem,anyone know.

 

I'm running XP Pro service pack2.

 

Regards

 

Tony.

Edited by AFB

Share this post


Link to post
Share on other sites

Also, with the above, try the following link:

http://www.appdeploy.com/faq/detail.asp?id=77

 

Thanks again but now I think I'm really screwed. I did the unreg bit but can't find any previouse windows updates with that error codeon so can't re reg. On the site you suggested I tried to download windows installer version 3.0 but my system said I don't need it as I already have service pack 2 installed.

 

Help

 

Tony.

Share this post


Link to post
Share on other sites

I'm a bit confused, did you do the msiexec /unregister command without doing the msiexec /regserver command? Please explain in more detail.

 

Thanks.

 

 

I did the unreg then the regserver command and still get error message windows installer error1601.

 

Then I went to microsoft web site and downloaded windows installer 3.1 I then went to live messenger.com to update and still got message cannot install due to 1601 error message.

 

Any ideas.

 

Tony

Share this post


Link to post
Share on other sites

Did you try this from the link I gave you:

If this fails to resolve your problem try performing the following steps:

 

1) Unregister Windows Installer:

 

msiexec /unregister

 

2) Rename the following files from the command prompt: Msi.dll, Msiexec.exe, and Msihnd.dll (by changing the names to msi.dll.bak, msiexec.exe.bak and msind.dll.bak respectively.)

3) Restart Windows.

4) Install the Windows Installer service again (InstMSI.exe). Don't have this? Check here.

 

Note: when attempting to delete/rename the MSI files Windows File Protection may keep you from being able to do so. One visitor suggests starting Windows in safe mode with a command prompt to deal to the 3 msi files.

 

? Edited by travyboy00

Share this post


Link to post
Share on other sites

Did you try this from the link I gave you:

 

?

 

Hi and thanks for your help. No I didn't try the bit about changing names because i'm nervous about what I might do to make things worse but I'm willing to give it a go with your help. Have you any idea what the screen looks like and can an idiot do it because I'm not to bright when it comes to these things.

 

Tony.

Share this post


Link to post
Share on other sites

Hi and thanks for your help. No I didn't try the bit about changing names because i'm nervous about what I might do to make things worse but I'm willing to give it a go with your help. Have you any idea what the screen looks like and can an idiot do it because I'm not to bright when it comes to these things.

 

Tony.

 

 

Hi all, I have benn trying to think back to what may have caused this problem. I was trying to update the templates in powerpoint and was prompted to insert my microsoft office 2002 cd,which I did but had a visitor and ejected the cd. I think I read somewhere that this could result in the loss of windows installer,anyone have any ideas as to how I can reinstall windows installer.

 

Regards

 

Tony.

Share this post


Link to post
Share on other sites

Hi all, I have benn trying to think back to what may have caused this problem. I was trying to update the templates in powerpoint and was prompted to insert my microsoft office 2002 cd,which I did but had a visitor and ejected the cd. I think I read somewhere that this could result in the loss of windows installer,anyone have any ideas as to how I can reinstall windows installer.

 

Regards

 

Tony.

 

 

Something odd just happened. Windows automatic updates just downloaded and installed 4 updates, so whats wrong,anyone.

 

Regards

 

Tony.

Share this post


Link to post
Share on other sites

This is a long one, but it's worth a try:

http://support.microsoft.com/kb/324516

 

 

Hi, I have managed to overcome the problem and everything is now OK.

 

If you go to start / run and type msconfig,click services tab and scroll down to windows installer it either says running or stopped,mine was stopped exit and go to run and type services.msc and scrol to windows installer against it will either be an empty space or if it's ok running. If it shows empty space click on manual and apply button and this will restart windows installer. It worked for me but don't forget I'm running windows XP Pro with SP2.

 

Very many thanks for all the help.

 

Regards

 

Tony.

Edited by AFB

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...