Jump to content
Sign in to follow this  
zizou

Can't open drives.........................

Recommended Posts

Hi there,

 

When i open My Computer and double click on any one of my drives to enter it, an 'Open With' menu would appear instead. The only way i can access my drives is by right-clicking on a drive and selecting 'Explore' to open it. What should i do to be able to open my drives directly once again via double-clicking on them?

Edited by zizou

Share this post


Link to post
Share on other sites

hello,

 

try visiting this link

 

CAUTION: Once downloaded, running this script changes your registry settings. Shogan

 

http://www.dougknox.com/xp/scripts/xp_folder_open.vbs

 

when you see finished!! at the bottom, try opening your drives again.

 

let us know if it fixes it.

Edited by shogan191

Share this post


Link to post
Share on other sites

Your intentions may be good posting scrip that is going to change a reg setting

with out posting how to return to the previous setting is not cool.

 

Bear

Share this post


Link to post
Share on other sites

for those that wish to study the script without clicking the link ;)

 

'folder_open.vbs - Fixes problem where Search opens on a double click
'© Doug Knox - 03/13/2002
'Downloaded from www.dougknox.com

Set WshShell = WScript.CreateObject("WScript.Shell")

p1 = "HKEY_CLASSES_ROOT\Directory\shell\"
p2 = "none"

WshShell.RegWrite p1, p2

p1 = "HKEY_CLASSES_ROOT\Drive\shell\"
WshShell.RegWrite p1, p2

X = WshShell.Run("REGSVR32 /I /S SHELL32.DLL",4,True)
Set WshShell = Nothing

MyBox = MsgBox("Folders will now Open when double clicked", 4096, "Finished!")

Share this post


Link to post
Share on other sites

hello,

 

try visiting this link

 

CAUTION: Once downloaded, running this script changes your registry settings. Shogan

 

http://www.dougknox.com/xp/scripts/xp_folder_open.vbs

 

when you see finished!! at the bottom, try opening your drives again.

 

let us know if it fixes it.

 

Doesn't help...

 

For everyone's info: This problem arose only after i removed several adwares, trojans and crappy stuff from my comp using Ewido anti-spyware. I think it could be due to the program removing an infected file which was required for my drives to open normally. My 1 cents' worth..

Share this post


Link to post
Share on other sites

since its file association and you dont have a backed up registry, theres a repair install or trust a google search

 

http://www.google.com/search?client=safari...-8&oe=UTF-8

 

Holy %@$#! Resetting the file associations almost f%$#ked my comp up. I couldn't boot up into windows after i merged the registry settings. Luckily something called 'Last good known configuration' saved me.

Share this post


Link to post
Share on other sites

I finally solved it on my own. Solution was to manually set the drive to 'open with' shellexplore.exe (file in system32 folder). Rebooted and all drives open normally again.

 

Thx to everyone who tried to help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...