Jump to content
Sign in to follow this  
Viking

Run out of memory

Recommended Posts

I think I need a way to free memory? Sometimes, after many hours of usage strange things happens. I think it's caused of too little memory available.

 

It recently happened, this time I had been browsing and chatting. More than 24 hours since last reboot. The software used includes IE, Wordpad and MSN Messenger.

 

Symptoms: Right-clicking in IE, or copy & paste text does not work properly when this happens. I also may have problems with getting the pc to respond on a reboot command. This time I had to use the Task Manager and shut down alot of things. After I shut down a certain process (forgot it's name), a message said the system would reboot within one minute. And it did.

 

When a IE window is closed, is not all the memory it used freed? I suspect it's not, and wonder if anyone can recommend a tool to fix this?

 

You may tell me to install more RAM, but I only got two RAM slots. And the 256 MB bricks to this pc is so expensive it is out of the question ($ 207 a piece). This pc had 192 MB RAM, now 320. That should be enough. I use old software and do not have Office installed.

 

The virtual memory is 480 MB. This gives a total of 800 MB memory.

 

Platform: XP Pro (SP1)

RAM: 64 + 128 + 128 = 320 MB (the first 64 cannot be replaced)

Share this post


Link to post
Share on other sites

Hi Viking,

 

Sounds like a "clipboard" related problem, since you mention copy/paste functions.

If this is central to the problem.... Empty the clipboard after pasting.

 

Best Regards

Share this post


Link to post
Share on other sites

Best advice I can give is Turn your computer off for at least 30 minutes every 24 hours. Thats trully the only way your memory can "discharge" its chips.

 

Post a link to your latest pit test. We might could tune it up alittle who knows.

Share this post


Link to post
Share on other sites

Hi Viking,

 

Sounds like a "clipboard" related problem, since you mention copy/paste functions.

If this is central to the problem.... Empty the clipboard after pasting.

 

Best Regards

 

The clipboard is very basic if you do not have Office. I don't think I can access it.

Share this post


Link to post
Share on other sites

Best advice I can give is Turn your computer off for at least 30 minutes every 24 hours. Thats trully the only way your memory can "discharge" its chips.

 

Post a link to your latest pit test. We might could tune it up alittle who knows.

 

I know a reboot or brief shutdown solve this problem. I just want to find another solution. And why 30 minutes? 1 minute should have the same effect? :huh:

 

I'll have to run a new pit test. The last is more than 6 months old.

 

 

 

 

 

Thanks for all responses. :)

Share this post


Link to post
Share on other sites

Okay.

 

well some people like to judge on the fact of how long a minute is. Some count to 60 some press the button and then press it agian and that was like a minute right?

 

so i just say a reasonable amout of time say 30 were as you will prbably just leave the room and come back later. Were in that senario 1 minute has definately passed. Plus Some memory is wierd and does take longer to discharge.

Share this post


Link to post
Share on other sites

When it happens, the pc isn't working properly. To reboot or shut down I can do, but now I have to do it before I have finished my work, because I never know when this happens.

 

I sometimes have trouble with shutting down the system!

Share this post


Link to post
Share on other sites

Say every 12 hours of 15 minute down time? Is this a server machine or just your personal computer or somone elses or both. Just turn it off when yoru not using it for a great amout of time. You gotta get some sleep sometime.

Share this post


Link to post
Share on other sites

The out of memory message has nothing to do with the pysical memory installed but rather the swap file/page file and poorly written programs not releasing the swap file. Solution is fairly easy to fix. Limit the number of background programs running for example auto updaters eat system resources/ swap file space. Set your page file/swap file to a minimum of 600mbs and a maximum of 1500 mbs and keep your system defragged.

Share this post


Link to post
Share on other sites

Say every 12 hours of 15 minute down time? Is this a server machine or just your personal computer or somone elses or both. Just turn it off when yoru not using it for a great amout of time. You gotta get some sleep sometime.

 

It's not a server, just a home pc. Some down time is ok, although it's easier said than done. However, I see this as avoiding the problem, I wish it could be solved. How soon this problem occurs depends, and when the memory has ran out, the pc is often not ready to reboot. Things must to be saved ++.

 

Here is the test results.

Edited by Viking

Share this post


Link to post
Share on other sites

The out of memory message has nothing to do with the pysical memory installed but rather the swap file/page file and poorly written programs not releasing the swap file. Solution is fairly easy to fix. Limit the number of background programs running for example auto updaters eat system resources/ swap file space. Set your page file/swap file to a minimum of 600mbs and a maximum of 1500 mbs and keep your system defragged.

 

I get no error message. I can try to increase the virtual memory, but whatever program is stealing memory will continue to do so.

Share this post


Link to post
Share on other sites

Viking... Here's a useful tweak from the Tom Coyote website.

I've used it on many PC's with excellent result.

Since the machine you're working on is relatively "low resource" it may be a good candidate.

 

After you follow Mouse's recommendation, give this a try.

 

Best Regards

Memory Loss? Not always a problem

 

Have you ever wondered why after spending some time working on your computer, that the more programs you open and close, the less available resources you have? You'd think that closing a program would free up any resources it takes up when running right? Wrong.

 

Windows has a DLL caching mechanism that keeps certain Dynamic Link Libraries (DLL files) loaded to help shorten the time it takes to open programs you use often. While this is a good idea in itself, it is only really useful when you use the same programs over and over and open and close them frequently.

 

This tip I've found quite some time ago turns off the DLL Caching "feature" and allows the unloading of all program-related DLL files upon closing the program that loaded them. This can and does in fact free up resources used and can also help gain overall stability of the system, especially if the computer is going to be run for long periods of time without restarting.

 

I've found two variants of this tip, one of which is labeled for Win9x family of the Windows platform (which includes Windows 95/98/98SE/ME), while the other was aimed at Windows XP. Although the Win9x tweak was tested on a XP system and verified to have the same result. So I'll give both here.

 

Win9x unload DLLs:

 

Go to Start - Run - type in "REGEDIT" without quotes and press enter. The Registry Editor opens up. Now use the lefthand explorer pane to find this key:

"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer" In the Righthand pane, right click in an empty space and choose "New... - String Value" and name it: "AlwaysUnloadDll" (without quotes and capital letters are important). Give this new string a value of 1, close the Registry Editor, and reboot Windows.

 

WinXP Unload DLLs: Go to Start - Run - type in "REGEDIT" without quotes and press enter. The Registry Editor opens up. Now use the lefthand explorer pane to find this key: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer" Still in the lefthand pane, right click on the Explorer folder and choose "New - KEY". Give it a name of "AlwaysUnloadDLL" (without quotes and capital letters are important). Inside that key change the default string to 1 and close regedit and reboot.

 

This tweak is perfect for low resource systems. The drawback of using this is a very small slowdown in the initial opening of programs, but this isn't half as bad as it sounds. And the benefit of using this tweak far outweighs the drawback.

Share this post


Link to post
Share on other sites

Thank you Dough. I have not tried to edit the registry yet, but I think I will, unless someone have another solution.

 

 

With a tool I installed, EVEREST Home Edition 2.01, I can monitor the usage of memory. I found something strange.

 

1. This program tells me I got:

319 MB physical memory

774 MB page file

=1094 MB virtual memory

 

 

2.

Today I again got the memory problem I talked about in my initial post. I tried to run EVEREST but could not. I closed a browser and then I could run EVEREST. EVEREST told me I only used 139 MB physical memory. About 180 MB free.

 

I shut down the pc 25 minutes. I boot it. Some time after all software is up and running, I ran EVEREST again. Now I used about 270 MB physical memory, only about 50 physical MB free! I used much less at the time I had memory difficulties.

 

 

3.

So I wonder, can it be that it's only the clipboard that is too full sometimes? And how do I empty it?

Share this post


Link to post
Share on other sites

Hate to tell you this doug, but that tweak has no effect in XP,

 

http://mywebpages.comcast.net/SupportCD/XPMyths.html

 

Myth - "Enabling this frees up more memory and improves performance"

 

Reality - "Adding this Registry Key in Windows 2000 or XP has no effect since this registry key is no longer supported in Microsoft Windows 2000 or later. The Shell automatically unloads a DLL when its usage count is zero, but only after the DLL has not been used for a period of time. This inactive period might be unacceptably long at times, especially when a Shell extension DLL is being debugged. For operating systems prior to Windows 2000, you can shorten the inactive period by adding this registry key."

and more about it here,

 

http://www.tweakhound.com/xp/xptweaks/supertweaks11.htm

 

about a third down the page.

Edited by stormy13

Share this post


Link to post
Share on other sites

you should set your paging memory to 3x your physical memory and make min and max the same size. that way windows doesnt have to compress the swap file.for instance on this box i have 512mb of ram and my swap file is 1500 min and 1500 max. hit ctrl+shift+esc to bring up itask manager click performance tab

like so http://img5.imageshack.us/img5/6084/newbitmapimage8xy.png look at commit charge,peak should never exceed limit keep an eye on that when your havin probs.

 

good resource http://www.theeldergeek.com/paging_file.htm

Edited by wicked clown

Share this post


Link to post
Share on other sites

What is this disabled device?

Media ESS Technology, Inc. ESS Maestro2E PCI AudioDrive (WDM)

Yeah Norton is a killer.

Share this post


Link to post
Share on other sites

you should set your paging memory to 3x your physical memory and make min and max the same size. that way windows doesnt have to compress the swap file.for instance on this box i have 512mb of ram and my swap file is 1500 min and 1500 max. hit ctrl+shift+esc to bring up itask manager click performance tab

like so http://img5.imageshack.us/img5/6084/newbitmapimage8xy.png look at commit charge,peak should never exceed limit keep an eye on that when your havin probs.

 

good resource http://www.theeldergeek.com/paging_file.htm

I see the size here is 480 - 960 MB. I wasn't aware there was more limits than a max limit, but there is a min too. :unsure:

Now all virtual memory is on the C disk, I wonder if it can be any problem with using the D disk too?

I'll look more into this tomorrow.

 

And here is my Task Manager. It's not in English, but it shouldn't be hard to figure out.

Share this post


Link to post
Share on other sites

What is this disabled device?

Media ESS Technology, Inc. ESS Maestro2E PCI AudioDrive (WDM)

Yeah Norton is a killer.

 

That's the soundcard in this notebook. Now I use an external card.

 

Norton a killer? Maybe, but for the most part it kills viruses I hope.

Share this post


Link to post
Share on other sites

norton is a system resource killer in that it uses way too many. Eset Nod32 is what i use and its worked very well.

 

newbitmapimage6nk.jpg

 

the initial size is the minimum and the max is max.set both to double the recommended amount.this way windows wont have to compress/decompress the swap file.putting the swap on d will help if its another physical drive and not just a partition of the same drive.

Edited by wicked clown

Share this post


Link to post
Share on other sites

you should set your paging memory to 3x your physical memory and make min and max the same size. that way windows doesnt have to compress the swap file.

 

I've now read abit on this, and the more I read the more I doubt on this Large System Cache tweak? I'm not sure and maybe I don't fully understand what I read.

 

Here is what make me doubt:

 

TweakHound. Scroll about half way down, look for "Large System Cache"

XP Myths. Scroll about half way down, look for "LargeSystemCache Tweak"

Microsoft article

 

I'm not running a server. Also, I have not understood how the min/max setting works. I imagine the page file like a disk. This "disk" have a maximum limit, in my case 960 MB. That's easy to understand. What I don't understand is how this "disk" can also have a minimum limit? The minimum limit is in my case 480 MB.

 

This can't mean the system must always put at least 480 MB in there? Where's the logic in that? And if I raise the minimum limit to 960 MB, it must always put no less than 960 MB in the page file?

 

I think I'll stop now, I just confuse myself. :P :crash:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...