Jump to content


Windows 7 Cannot Connect To Internet (driver)

  • Please log in to reply
2 replies to this topic

#1 samiyar09


    New Member

  • Members
  • 1 posts

Posted 19 March 2011 - 09:02 PM

Hello I recently updated my old computer to a windows 7 64bit. It cannot connect to the internet because a driver was not properly installed, i tried enable/disable but that did not work. I also tried downloading other drivers e.g lan drivers, modem drivers and tried diagnosing it myself. The only solution is to do a windows update which requires an internet connection. I tried downloading driver updaters but they needed a internet connection to start too. I have tried almost anything and I know myself around a computer pretty well. I tried uninstalling it (it was my last choice) to see if windows would automatically do something but with no luck. My computer is an Acer Aspire SA80. I checked the website and no ethernet drivers were there. I might ring my ISP and hopefully they can help me because the internet was working well before i upgraded to windows 7. I have also read that others have this problem too.

#2 badbob


    Advanced Member

  • Advanced Member
  • 932 posts
  • Gender:Male
  • Location:dog house

Posted 19 March 2011 - 11:25 PM

I think you might be better off getting a new network card for your computer.
Give this forum a read if want to try and get it working.

#3 Joe C

Joe C

    Advanced Member

  • Advanced Member
  • 18,988 posts
  • Gender:Male
  • Location:Northwestern Southeast Michigan

Posted 20 March 2011 - 08:47 PM

I've had that problem before. what I did was to install a compatible ethernet card in the pci slot, get it on line and then have windows download the drivers for your Realtek 8201 CL 10/100 on board device. Once you have that you can remove the pci card. There is the possibility that drivers for an older card are not available via windows update for windows 7, in which case you'll need a new ethernet card any way. If you have spare ethernet cards lying around, see if you can use one of those

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users