Jump to content


Photo

Linux Mint 13 does nothing


  • Please log in to reply
20 replies to this topic

#1 SoulFly

SoulFly

    Member

  • Members
  • 184 posts
  • Gender:Male



Posted 14 July 2012 - 06:12 PM

what i got
core i7
16 gigs ram
nvidia video
corsair ssd
asus maximus v gene motherboard

what i'm doing
Dual booting. Have Mint 13 on USb drive. Boot devices shows 2 options for this drive, one has the prefix of "UEFI". Both give me same result.
Menu pops up with option booting Linux, compatability mode or check for consistancy which shows it as being ok.

Problem
Selecting to run Mint, screen goes blank, mouse cursor pops up....the end.
Selecting to run compatability mode, texts scroll, eventually message says Xserver GUI won't load or some such.
Selecting device to boot either UEFI prefix option or not had same result.

what i tried
different USB drive, iso's from other servers, 32bit, 64bit, different distros, different usb ports, different bios settings.
Googling didn't turn up much, some jargon about how linux won't run on UEFI or whatever, but nothing that seemed to offer any other possibilities or solutions. I noticed other distro's mentioned as well under searching this problem, so i take it that its universal but i want to use Mint in particular as it seems more adequate for someone like me from what i've read. so i thought anyway. Linux forums, couple others. no response yet, trying to spread out the question for more responses but no responses. lol

My past experiences with Linux required me jumping through ridiculous hoops, i see nothing has changed. Windows installed without a hitch, so i know its not hardware related but why can't Linux work as easy?
this problem has literally wasted most of my day, sadly, its aggravating enough to make one want to do a youtube video in response to all the Linux videos showing how easy it is, but i know my problem is probably minority. i'm time invested enough i might as well try some alternative suggestions.
thanks in advance.

Edited by SoulFly, 14 July 2012 - 06:14 PM.

Disclaimer:
By reading the above post you adhere and agree to all that is written. You may not opinion-ate, comment nor question. Response is a direct violation of this agreement

#2 terry1966

terry1966

    Advanced Member

  • Anti-Spyware Brigade
  • 8,622 posts
  • Gender:Male
  • Location:Abingdon..UK.


Posted 14 July 2012 - 07:16 PM

how did you install mint on the usb drive? i really don't understand why your having a problem booting the usb drive when choosing the first boot drive in bios if mint was installed correctly to the usb drive. only problem i believe is when you try and dual boot from a single gpt formatted hard drive. maybe this will help you. :- http://community.lin...torial/view/858 i'd install mint again but this time unplug your win 7 hard drive first and then install mint to the usb drive, see if that solves your problem. :b33r:

Edited by terry1966, 14 July 2012 - 07:29 PM.


#3 adam22

adam22

    Open Your Mind

  • Advanced Member
  • 2,299 posts
  • Gender:Male
  • Location:New Jersey



Posted 14 July 2012 - 07:19 PM

I use unetbootin to make my usb drives bootable with Linux. I took a video of a relatively unknown linux distro booting up, it looks like this:

#4 Bruce

Bruce

    Geezer

  • Grand Poobah
  • 42,551 posts
  • Gender:Male
  • Location:Wales Massachusetts


Posted 14 July 2012 - 08:24 PM

what i got
core i7
16 gigs ram
nvidia video
corsair ssd
asus maximus v gene motherboard

what i'm doing
Dual booting. Have Mint 13 on USb drive. Boot devices shows 2 options for this drive, one has the prefix of "UEFI". Both give me same result.
Menu pops up with option booting Linux, compatability mode or check for consistancy which shows it as being ok.

Problem
Selecting to run Mint, screen goes blank, mouse cursor pops up....the end.
Selecting to run compatability mode, texts scroll, eventually message says Xserver GUI won't load or some such.
Selecting device to boot either UEFI prefix option or not had same result.

what i tried
different USB drive, iso's from other servers, 32bit, 64bit, different distros, different usb ports, different bios settings.
Googling didn't turn up much, some jargon about how linux won't run on UEFI or whatever, but nothing that seemed to offer any other possibilities or solutions. I noticed other distro's mentioned as well under searching this problem, so i take it that its universal but i want to use Mint in particular as it seems more adequate for someone like me from what i've read. so i thought anyway. Linux forums, couple others. no response yet, trying to spread out the question for more responses but no responses. lol

My past experiences with Linux required me jumping through ridiculous hoops, i see nothing has changed. Windows installed without a hitch, so i know its not hardware related but why can't Linux work as easy?
this problem has literally wasted most of my day, sadly, its aggravating enough to make one want to do a youtube video in response to all the Linux videos showing how easy it is, but i know my problem is probably minority. i'm time invested enough i might as well try some alternative suggestions.
thanks in advance.


Have you ever installed windows on a usb hard drive?

Is this an OEM system or one that you built?

Some OEM systems lock the eufi bios from booting other systems.

Needless to say you haven't provided much information other then to complain that it doesn't work.

Have you tried installing to an internal hard drive?

Edited by Bruce, 14 July 2012 - 08:26 PM.

http://itsyourpc.org

Microsoft blew its right foot off with Windows 8.
They went to the doctor to get it reattached with Windows 8.1 only to wake up to find out that a second left foot was attached in place.


#5 numerounoyankeefan

numerounoyankeefan

    Member

  • Members
  • 170 posts
  • Gender:Male


Posted 15 July 2012 - 06:19 AM

try adding "nomodeset" to the boot parameters.

when you boot up, do you at least get to the grub screen (where you have choices to boot into mint, recovery mode, memtest, etc...)?

if yes, then when you see the menu, press "F6" and you may see some boot parameter options (works in ubuntu, not sure about mint)....if you see the options, scroll down (use up/down arrow keys) and highlite "nomodeset". then press "esc" to get off the option choices, and press enter to boot.

if pressing "F6" does not bring up those options...you will have to add it manually:

at the grub screen....highlite the first line of the grub menu (use up/down arrows to navigate) and press the "e" key. next use the right/left arrow keys to move the cursor to the end of the line that starts with "linux" (the line may wrap around/continue onto the next line, so make sure you scroll all the way to the end). now type one space and after that type:

nomodeset

then press the "ctrl" and "x" keys together to boot.

hope that helps.

#6 SoulFly

SoulFly

    Member

  • Members
  • 184 posts
  • Gender:Male



Posted 15 July 2012 - 07:03 AM

i used unetootin and universal usb installer also i have one usb that is a special boot drive, it will boot anything. i use it for windows all the time ..same issue obviously they must work or i wouldnt get as far as i have to further note. other distros dont do much more either...like fedora will hang at the options screen where it says to try fedora 17 or install to hrdrive mouse moves but thats it also...boot parameters? i see no where to type anything but yes i get past grub screen...like i said, isee mouse cursor but the rest hangs...fedora, ubuntu...etc it hangs before i can even use live cd t i dont oc or anything...stock settings, i think its the uefi bios...at least thats what google suggests

Edited by SoulFly, 15 July 2012 - 07:06 AM.

Disclaimer:
By reading the above post you adhere and agree to all that is written. You may not opinion-ate, comment nor question. Response is a direct violation of this agreement

#7 numerounoyankeefan

numerounoyankeefan

    Member

  • Members
  • 170 posts
  • Gender:Male


Posted 15 July 2012 - 09:23 AM

ok i guess its different for mint (i use ubuntu)....when you see the grub menu, try pressing the "tab" key, you should see a command line

use < > arrow keys to scroll to the end of the line and add "nomodeset" (without the quotes of course) after quiet splash but before the dash (-) at the end, like this:

before:
quiet splash –

after:
quiet splash nomodeset –

then press enter or the ctrl and x keys to boot.

#8 SoulFly

SoulFly

    Member

  • Members
  • 184 posts
  • Gender:Male



Posted 15 July 2012 - 10:57 AM

Update: i decided to try burning a DVD image. I still got the same issue in normal boot, however, i finally have made it to the Live CD desktop using recovery mode. i tried to install to disk and it did so but i can only boot to recovery mode and i see the error posted in below picture. perhaps its a graphical driver issue? This is about the best i can come up with. i took a picture of this error..but at least i'm getting somewhere now. I havn't tried the commands you posted numerounoyankeefan yet, but after i look up how to install graphic drivers, i'll give that a shot http://img690.images...0/dscf1122g.jpg
Disclaimer:
By reading the above post you adhere and agree to all that is written. You may not opinion-ate, comment nor question. Response is a direct violation of this agreement

#9 SoulFly

SoulFly

    Member

  • Members
  • 184 posts
  • Gender:Male



Posted 15 July 2012 - 11:33 AM

alrighty then. i realized i'm incapable of figuring out how to install the graphics drivers. i downloaded the latest. i googled how to do it which required me to press cntrl alt F1 to bring up some crazy console that i can't seem to get out of, but after typing lots of commands it says cannot run nvidia-linux-x86_64-295.59.run i give up. whats the secret here. i'm still forced to use recovery mode which is getting on my nerves. I'm left to assume its because i don't have the video drivers, i prefer the way Windows handles not having video drivers but whatever. I can only hope i don't have to write some 50 line programming code just to get some drivers.
Disclaimer:
By reading the above post you adhere and agree to all that is written. You may not opinion-ate, comment nor question. Response is a direct violation of this agreement

#10 Bruce

Bruce

    Geezer

  • Grand Poobah
  • 42,551 posts
  • Gender:Male
  • Location:Wales Massachusetts


Posted 15 July 2012 - 01:22 PM

This will be my last post here. One simple command will install everything needed for a newer nvidia card. sudo apt install nvidia-kernel-dkms nvidia-glx build-essential nvidia-settings nvidia-xconfig Information was as simple to find as a two word google search. http://forums.linuxm...p?t=82424&f=191

Edited by Bruce, 15 July 2012 - 01:23 PM.

http://itsyourpc.org

Microsoft blew its right foot off with Windows 8.
They went to the doctor to get it reattached with Windows 8.1 only to wake up to find out that a second left foot was attached in place.


#11 SoulFly

SoulFly

    Member

  • Members
  • 184 posts
  • Gender:Male



Posted 15 July 2012 - 03:29 PM

Apparently drivers doesnt work. seems installed but rebooted several times and no graphics. i'm stuck on 1280 resolution and for some reason it detects my monitor as a laptop monitor with no higher resolution size. mine is 1080p native.

trying to open nvidia settings tool...*ahem...according to google again. it simply says to type some commands (yay command lines)
but responds saying "no such job"

yet under nv x server it says

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

yet xconfig says it can't find

To top that off, under "additional Drivers" settings, it says the Nvidia drivers are activated and in use.
i also can't make cinnamon desktop work
Disclaimer:
By reading the above post you adhere and agree to all that is written. You may not opinion-ate, comment nor question. Response is a direct violation of this agreement

#12 SoulFly

SoulFly

    Member

  • Members
  • 184 posts
  • Gender:Male



Posted 15 July 2012 - 03:34 PM

This will be my last post here.

One simple command will install everything needed for a newer nvidia card.

sudo apt install nvidia-kernel-dkms nvidia-glx build-essential nvidia-settings nvidia-xconfig

Information was as simple to find as a two word google search.

http://forums.linuxm...p?t=82424&f=191


simple?
when i tried your method i got this in response. i copied and pasted directly. I'm sooo glad all this is simple to you however. But you can help others without the sarcasm. i mean it is possible.
btw i've been using google and bing for 2 days straight attempting to solve issues...so give me a break eh?

Package nvidia-glx is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package nvidia-kernel-dkms
E: Package 'nvidia-glx' has no installation candidate
E: Unable to locate package nvidia-xconfig
mike@Linux ~ $



Edited by SoulFly, 15 July 2012 - 03:35 PM.

Disclaimer:
By reading the above post you adhere and agree to all that is written. You may not opinion-ate, comment nor question. Response is a direct violation of this agreement

#13 joncr

joncr

    New Member

  • Members
  • 1 posts

Posted 16 July 2012 - 06:00 AM

The combination of a small number of Nvidia cards, Linux kernels from the 3.2 and 3.3 series, and the open source Nouveau video driver for Nvidia cards will produce the symptoms you report. The problem arises because Linux distributions cannot distribute the Nvidia driver on their CD/DVD's. When the installation routine detects an Nvidia card, it attempts to load the Nouveau driver. That triggers the problem. The solution for me has been to add "nouveau.noaccel=1 nomodeset" to the kernel boot line, as explained earlier in this thread. Nomodeset, alone, does not work for me. That allows me to boot successfully, into a low resolution environment. The next thing I do after booting, is to install the proprietary Nvidia driver. Linux Mint has a program called "Additional Drivers" that does this. If you wait a few minutes after booting, the system should display a message that Additional Drivers are available. If it does not, or if you are in a hurry, look for "Additional Drivers" in the menu tree. It should be listed under "System" or "Adminstration", if memory serves. "Additional Drivers" will likely offer you two choices. The first will be the Nvidia proprietary driver that was available at the time Mint was packaged for release. The second is described as post-release updates, but it is, in fact, a more current dirver. Either option is OK, but I recommend the second. "Additional Drivers" will prompt you for a password, then download and install the driver. It may take a few minutes. You will then be prompted to reboot. I have noticed that at least one current version of the Nvidia proprietary driver package does not actually create the necessary xorg.conf file. (I've also seen this in the Nvidia package from the Nvidia site, so I attribute to that routine.)I recommend opening a terminal and entering this command: ls -l /etc/X11/xorg.conf. If you do not see a listing for xorg.conf with a current date stamp, then xorg.conf was not created. In the terminal window, enter: "sudo nvidia.xconfig" which will create xorg.conf. Reboot and you should come up running the Nvidia driver. An Nvidia configuration tool will be installed, as well. Good luck. This Nvidia-Nouveau-kernel problem is obviously annoying for those with the affected cards. But, in the end, it exists because Nvidia is a closed proprietary product whose code is not available to Linux developers.

#14 adam22

adam22

    Open Your Mind

  • Advanced Member
  • 2,299 posts
  • Gender:Male
  • Location:New Jersey



Posted 16 July 2012 - 08:57 AM

This guy appears to have signed up just to answer your question, SoulFly. Not to be the righteous and moral police, but when you have an attitude towards something/someone, people will not help you again. Be appreciative, be patient. You are having a tough time, we get it, but for every one case like this, there could be 5,000 without issue. When dealing with newer or older technologies or closed source code, sometimes things aren't smooth, but that does not mean everyone has issues.

#15 SoulFly

SoulFly

    Member

  • Members
  • 184 posts
  • Gender:Male



Posted 16 July 2012 - 05:24 PM

The combination of a small number of Nvidia cards, Linux kernels from the 3.2 and 3.3 series, and the open source Nouveau video driver for Nvidia cards will produce the symptoms you report.

The problem arises because Linux distributions cannot distribute the Nvidia driver on their CD/DVD's. When the installation routine detects an Nvidia card, it attempts to load the Nouveau driver. That triggers the problem.

The solution for me has been to add "nouveau.noaccel=1 nomodeset" to the kernel boot line, as explained earlier in this thread. Nomodeset, alone, does not work for me.

That allows me to boot successfully, into a low resolution environment.

The next thing I do after booting, is to install the proprietary Nvidia driver. Linux Mint has a program called "Additional Drivers" that does this. If you wait a few minutes after booting, the system should display a message that Additional Drivers are available.

If it does not, or if you are in a hurry, look for "Additional Drivers" in the menu tree. It should be listed under "System" or "Adminstration", if memory serves.

"Additional Drivers" will likely offer you two choices. The first will be the Nvidia proprietary driver that was available at the time Mint was packaged for release. The second is described as post-release updates, but it is, in fact, a more current dirver. Either option is OK, but I recommend the second.

"Additional Drivers" will prompt you for a password, then download and install the driver. It may take a few minutes. You will then be prompted to reboot.

I have noticed that at least one current version of the Nvidia proprietary driver package does not actually create the necessary xorg.conf file. (I've also seen this in the Nvidia package from the Nvidia site, so I attribute to that routine.)I recommend opening a terminal and entering this command: ls -l /etc/X11/xorg.conf. If you do not see a listing for xorg.conf with a current date stamp, then xorg.conf was not created. In the terminal window, enter: "sudo nvidia.xconfig" which will create xorg.conf. Reboot and you should come up running the Nvidia driver. An Nvidia configuration tool will be installed, as well.

Good luck. This Nvidia-Nouveau-kernel problem is obviously annoying for those with the affected cards. But, in the end, it exists because Nvidia is a closed proprietary product whose code is not available to Linux developers.


most informative and well explained thank you. However "additional drivers" did not work, it was the first thing i actually did after install and have since tried it a couple more times as well as the "second option". I see where it says "activated" however it is clearly not. I have a "recovery mode like environment" and low resolution. I can't seem to make it change to anything else. It also reports my monitor as a "laptop" which it is actually a HD 3d TV. 32" 1080p.

Since then i have looked up countless commands, most were not successful, the ones that seemed to work...meaning i got to end of terminal with some sort of successful result...did not actually do anything after a reboot.

i read of things stating to disable the x server or x org?? to cntrl/al/F1 and type some stuff. but the funny thing is, a lot of posted information about linux is not always explained very well and have been unsuccessful...perhaps something is mistyped or i am mistyping.

i will continue further in my research and enter in your command of ls -l /etc/X11/xorg.conf and see how all that goes...despite other smaller issues i have, this is my main hurdle i believe. I'll update on any progress.


This guy appears to have signed up just to answer your question, SoulFly. Not to be the righteous and moral police, but when you have an attitude towards something/someone, people will not help you again. Be appreciative, be patient. You are having a tough time, we get it, but for every one case like this, there could be 5,000 without issue. When dealing with newer or older technologies or closed source code, sometimes things aren't smooth, but that does not mean everyone has issues.


informing someone they can post without the sarcasm is not really an "attitude" as you say so much as it is disciplining against unnecessary comments.
there is witty sarcasm and know it all sarcasm. When you present information and add such comments which can elude to someone else perceiving that as some sort of insult without attempting to assemble beforehand, then you can expect some sort of negative reaction. a negative divided does not equal a positive. In other words, the way i see it, he purposefully laid blame solely on me as if i am negligent in my searches despite so much effort and hours of reading and trying different things only to discover that his method did not work...which would otherwise be fine if he omitted the "know it all" sarcasm

keep in mind this isn't the first time i noticed posts from this particular member presenting a very sarcastic demeanor in historic postings and is now on my block list so i won't have to witness it further.
Your opinion of the situation holds the same weight as mine, so no response is really necessary on the subject as i'm merely explaining to you why i reacted in my disciplining, but it is imo, that getting information in a negative way, is not worth obtaining that information and depreciates the appreciation. Meaning i'd rather not get any help at all if someone has to innuendo that i'm stupid or negligent.

i appreciate your informing me of the previous poster registering just to help, which was itself very informative and appreciated as you can see not a hint of sarcasm anywhere :)

Edited by SoulFly, 16 July 2012 - 05:28 PM.

Disclaimer:
By reading the above post you adhere and agree to all that is written. You may not opinion-ate, comment nor question. Response is a direct violation of this agreement

#16 SoulFly

SoulFly

    Member

  • Members
  • 184 posts
  • Gender:Male



Posted 16 July 2012 - 05:40 PM

I recommend opening a terminal and entering this command: ls -l /etc/X11/xorg.conf. If you do not see a listing for xorg.conf with a current date stamp, then xorg.conf was not created. In the terminal window, enter: "sudo nvidia.xconfig" which will create xorg.conf. Reboot and you should come up running the Nvidia driver. An Nvidia configuration tool will be installed, as well.[/size]]


seems xorg.conf was created...whatever that is. just out of curiosity i also typed in sudo nvidia.xconfig but resulted in "command not found" either way, still no functioning driver. It is a 5800gtx which fairly new, so perhaps there just is no support for it.

mike@Linux ~ $ ls -l /etc/X11/xorg.conf
-rw-r--r-- 1 root root 1196 Jul 15 17:59 /etc/X11/xorg.conf


Edited by SoulFly, 16 July 2012 - 05:42 PM.

Disclaimer:
By reading the above post you adhere and agree to all that is written. You may not opinion-ate, comment nor question. Response is a direct violation of this agreement

#17 Bruce

Bruce

    Geezer

  • Grand Poobah
  • 42,551 posts
  • Gender:Male
  • Location:Wales Massachusetts


Posted 16 July 2012 - 06:20 PM

My guess is the previous poster made a typo without realizing it. nvidia-xconfig is the proper command

http://itsyourpc.org

Microsoft blew its right foot off with Windows 8.
They went to the doctor to get it reattached with Windows 8.1 only to wake up to find out that a second left foot was attached in place.


#18 adam22

adam22

    Open Your Mind

  • Advanced Member
  • 2,299 posts
  • Gender:Male
  • Location:New Jersey



Posted 16 July 2012 - 09:29 PM

My guess is the previous poster made a typo without realizing it.

nvidia-xconfig is the proper command


Too bad he ignored you LOL

#19 Bruce

Bruce

    Geezer

  • Grand Poobah
  • 42,551 posts
  • Gender:Male
  • Location:Wales Massachusetts


Posted 17 July 2012 - 03:15 AM

From the very first post it was apparent that finding a solution was not the goal here. ;)

http://itsyourpc.org

Microsoft blew its right foot off with Windows 8.
They went to the doctor to get it reattached with Windows 8.1 only to wake up to find out that a second left foot was attached in place.


#20 SoulFly

SoulFly

    Member

  • Members
  • 184 posts
  • Gender:Male



Posted 17 July 2012 - 08:25 PM

I now went through qiute a number of various commands regarding video drivers. Out of the several commands for restarting x server, only one particular functioned which seemed odd as they say any of those would work. So it seemed no method ordriver version actually makes it function. I also noticed i lost my clock and running tasks on far right side for no reason seemingly. So i gave ubuntu a shot using dvd, but now back to same issue i had from usb on mint, fedora...etc Where mint would run with uefi off but only from dvd, this one wont on either, nor usb Non uefi, i can make it to a blank welcome screen ...nomodest method i cant even make it that far. Outside of speculating that there is no working support in linux for some modern hardwares, i would guess maybe a 64 bit issue as i never tried 32 bit But i give up...linux beat me. Advertise all they want, im sure linux is easy in most situations, but encounter an issue and that goes out the window. My hardware will get more common eventually, hopefully more will complain so it can get some solution or diagnostic at least.

Edited by SoulFly, 17 July 2012 - 08:27 PM.

Disclaimer:
By reading the above post you adhere and agree to all that is written. You may not opinion-ate, comment nor question. Response is a direct violation of this agreement




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users