Jump to content


Photo

Desktop effects, stop transparent taskbar.


  • Please log in to reply
34 replies to this topic

#1 KRAM

KRAM

    Advanced Member

  • Advanced Member
  • 10,014 posts
  • Gender:Male


Posted 31 January 2009 - 11:36 AM

When I enable desktop effects the taskbar goes transparent. I can not find anywhere within the settings to make the taskbar solid. How do I make the taskbar solid with desktop effects on? Thanks.

#2 duanester

duanester

    OpenSuSe Movement

  • Anti-Spyware Brigade
  • 21,446 posts
  • Gender:Male
  • Location:Michigan


Posted 31 January 2009 - 12:15 PM

i had the same problem when i used 10.3 changing transparency % helped, i never found a way to stop it. their is no settings specific to the bar' so adjusting transparency will affect everything. i haven't tried it in 11.1
When you have eliminated the impossible, whatever remains, however improbable, must be the truth !!
Join the next generation of computing, Open Source, and Linux/GNU!
"nvidia license taints kernel"

#3 Bruce

Bruce

    Geezer

  • Grand Poobah
  • 42,478 posts
  • Gender:Male
  • Location:Wales Massachusetts


Posted 31 January 2009 - 12:25 PM

KDE's native desktop effevcts? Or Compiz-Fusion? If KDE's native effects what theme are you using? Also when you say transparent, do you mean it disappears totally or just has transparency?

Edited by Bruce, 31 January 2009 - 12:28 PM.

http://itsyourpc.org

Microsoft blew its right foot off with Windows 8.
They went to the doctor to get it reattached with Windows 8.1 only to wake up to find out that a second left foot was attached in place.


#4 KRAM

KRAM

    Advanced Member

  • Advanced Member
  • 10,014 posts
  • Gender:Male


Posted 31 January 2009 - 01:15 PM

Transparency. The taskbar is there, I want it to be solid though. I would assume it's KDE Native Effects since I do not have Compiz installed, but it has wobbly windows and 3D Cube effects in it. Nothing in Transparency settings effects the taskbar.

#5 duanester

duanester

    OpenSuSe Movement

  • Anti-Spyware Brigade
  • 21,446 posts
  • Gender:Male
  • Location:Michigan


Posted 31 January 2009 - 01:26 PM

i think when transparency is enabled' changing the theme to aya or oxygen prevents transparency in that panel bar.

what theme is it set to now ?

edit: http://forum.kde.org...d.php?tid=24232 it's not looking good

Edited by duanester, 31 January 2009 - 01:29 PM.

When you have eliminated the impossible, whatever remains, however improbable, must be the truth !!
Join the next generation of computing, Open Source, and Linux/GNU!
"nvidia license taints kernel"

#6 KRAM

KRAM

    Advanced Member

  • Advanced Member
  • 10,014 posts
  • Gender:Male


Posted 31 January 2009 - 02:07 PM

I have Oxygen theme selected.

#7 duanester

duanester

    OpenSuSe Movement

  • Anti-Spyware Brigade
  • 21,446 posts
  • Gender:Male
  • Location:Michigan


Posted 31 January 2009 - 02:09 PM

so your saying decreasing transparency has no affect on the panel bar ?
When you have eliminated the impossible, whatever remains, however improbable, must be the truth !!
Join the next generation of computing, Open Source, and Linux/GNU!
"nvidia license taints kernel"

#8 duanester

duanester

    OpenSuSe Movement

  • Anti-Spyware Brigade
  • 21,446 posts
  • Gender:Male
  • Location:Michigan


Posted 31 January 2009 - 02:14 PM

here is a thread when i griped about the panel transparency :lol:

http://forums.pcpits...hl=transparency
When you have eliminated the impossible, whatever remains, however improbable, must be the truth !!
Join the next generation of computing, Open Source, and Linux/GNU!
"nvidia license taints kernel"

#9 KRAM

KRAM

    Advanced Member

  • Advanced Member
  • 10,014 posts
  • Gender:Male


Posted 31 January 2009 - 02:28 PM

I would think there is a setting that I am missing somewhere as when I turn off desktop effects the taskbar goes back to a solid color, no transparency.

#10 duanester

duanester

    OpenSuSe Movement

  • Anti-Spyware Brigade
  • 21,446 posts
  • Gender:Male
  • Location:Michigan


Posted 31 January 2009 - 02:45 PM

since we advanced a bit since' there is probably a config file somewhere, where is the question ? bruce may know the answer to it
When you have eliminated the impossible, whatever remains, however improbable, must be the truth !!
Join the next generation of computing, Open Source, and Linux/GNU!
"nvidia license taints kernel"

#11 duanester

duanester

    OpenSuSe Movement

  • Anti-Spyware Brigade
  • 21,446 posts
  • Gender:Male
  • Location:Michigan


Posted 31 January 2009 - 03:13 PM

i did find something we can study, it's a lot to look at though

i found it in /usr/bin/compiz

i am currently running ubuntu, your situation may be different



COMPIZ_BIN_PATH="/usr/local/bin/" # For window decorators and compiz
PLUGIN_PATH="/usr/local/lib/compiz/" 
GLXINFO="/usr/bin/glxinfo"
KWIN="/usr/bin/kwin"
METACITY="/usr/bin/metacity"
COMPIZ_NAME="compiz" # Final name for compiz (compiz.real) 



edited: those appear to be the directories, this only affects ubuntu, i edited out the mumbo jumbo

i will check /use/local/bin, it looks like all the window settings are there

Edited by duanester, 31 January 2009 - 03:27 PM.

When you have eliminated the impossible, whatever remains, however improbable, must be the truth !!
Join the next generation of computing, Open Source, and Linux/GNU!
"nvidia license taints kernel"

#12 KRAM

KRAM

    Advanced Member

  • Advanced Member
  • 10,014 posts
  • Gender:Male


Posted 31 January 2009 - 04:33 PM

Installed Compiz from Yast. Still do not see any settings for the taskbar transparency.

#13 KRAM

KRAM

    Advanced Member

  • Advanced Member
  • 10,014 posts
  • Gender:Male


Posted 31 January 2009 - 05:20 PM

This must be something to do with KDE 4.2. I remember seeing options that are no longer available. Things like add new default panel, and one about colorize taskbar to desktop theme or something like that.

#14 KRAM

KRAM

    Advanced Member

  • Advanced Member
  • 10,014 posts
  • Gender:Male


Posted 31 January 2009 - 06:23 PM

I have no clue. Used to have a curved taskbar with nice blue outline around the task manager. All gone. :cr@sh:

#15 Bruce

Bruce

    Geezer

  • Grand Poobah
  • 42,478 posts
  • Gender:Male
  • Location:Wales Massachusetts


Posted 31 January 2009 - 06:46 PM

It has nothing to do with Compiz, disregard anything about Compiz, in fact you can remove it completely from the system. KDE has effects natively and doesn't use a third party application for it's effects. With that out of the way :lol: Where are you selecting the theme from? There are window decorations in configure desktop in the menu n=but those are not related to to what you are seeing. The theme responsible for the taskbar and what is seen on the "desktop" is in a setting on the desktop. Right click on the desktop and select appearance settings, there the default choice for the desktop is aya, and or oxygen, you can also select the option to get more themes which will download and install any theme that is available at KDE-Look.org. I use "Slim Glow" which has a transparent taskbar. The aya theme and oxygen theme do not use a transparent taskbar. Even with effects on the Oxygen theme tasbar is not transparent, and has the blue outline around items in the tasbar.

http://itsyourpc.org

Microsoft blew its right foot off with Windows 8.
They went to the doctor to get it reattached with Windows 8.1 only to wake up to find out that a second left foot was attached in place.


#16 KRAM

KRAM

    Advanced Member

  • Advanced Member
  • 10,014 posts
  • Gender:Male


Posted 31 January 2009 - 06:51 PM

Soon as I enable desktop effects the taskbar goes into tranparency with Oxygen. Aya theme stays solid, but what a nasty theme Aya is :yucky: Also I'm pretty sure the curved looking taskbar with blue lining around task manager items happens when you go to KDE 4.2.

Edited by KRAM, 31 January 2009 - 07:11 PM.


#17 Bruce

Bruce

    Geezer

  • Grand Poobah
  • 42,478 posts
  • Gender:Male
  • Location:Wales Massachusetts


Posted 31 January 2009 - 06:57 PM

Wkat version of KDE are you using?

http://itsyourpc.org

Microsoft blew its right foot off with Windows 8.
They went to the doctor to get it reattached with Windows 8.1 only to wake up to find out that a second left foot was attached in place.


#18 Bruce

Bruce

    Geezer

  • Grand Poobah
  • 42,478 posts
  • Gender:Male
  • Location:Wales Massachusetts


Posted 31 January 2009 - 06:59 PM

Just checked my wifes machine (KDE4.1) The oxygen theme is certainly different on her machine.

http://itsyourpc.org

Microsoft blew its right foot off with Windows 8.
They went to the doctor to get it reattached with Windows 8.1 only to wake up to find out that a second left foot was attached in place.


#19 KRAM

KRAM

    Advanced Member

  • Advanced Member
  • 10,014 posts
  • Gender:Male


Posted 31 January 2009 - 07:11 PM

I was using 4.2 and in trying to get the transparency on taskbar to stop when selecting desktop effects I went back to 4.1, but it did not help.

#20 duanester

duanester

    OpenSuSe Movement

  • Anti-Spyware Brigade
  • 21,446 posts
  • Gender:Male
  • Location:Michigan


Posted 31 January 2009 - 07:32 PM

It has nothing to do with Compiz, disregard anything about Compiz, in fact you can remove it completely from the system. KDE has effects natively and doesn't use a third party application for it's effects.



dang, my bad' it's kwin :lol:

http://en.wikipedia.org/wiki/KWin


:tup:


maybe bruce can tell us about it's config files :rolleyes:

maybe it's as easy as editing one ?
When you have eliminated the impossible, whatever remains, however improbable, must be the truth !!
Join the next generation of computing, Open Source, and Linux/GNU!
"nvidia license taints kernel"




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users