Jump to content


Photo

Corrupted WAN Miniport(PPPOE) driver


  • Please log in to reply
7 replies to this topic

#1 jvin

jvin

    Member

  • Members
  • 19 posts

Posted 28 December 2008 - 06:08 PM

Hi, I've IBM Thinkpad with Windows XP. My laptop was infected with Spyware. With great help from PC pitstop forum, I could successfully clean the system. Some of the drivers were corrupted too. I was able to uninstall them and after rebooting they are fine. When I try to uninstall WAN Miniport (PPPOE), I get error message "Failed to uninstall. The device may be required to boot up the computer". Can some one please tell me how to fix this? Thanks, jvin.

#2 Jacee

Jacee

    Madam Admin <aka> Maude

  • Admins
  • 27,700 posts
  • Gender:Female


Posted 28 December 2008 - 08:29 PM

See if fixing the winsock works before trying to uninstall Wan Miniport

http://www.snapfiles...nsockxpfix.html

MS - MVP Consumer Security 2006 thru 2014


#3 jvin

jvin

    Member

  • Members
  • 19 posts

Posted 29 December 2008 - 01:59 PM

See if fixing the winsock works before trying to uninstall Wan Miniport

http://www.snapfiles...nsockxpfix.html



When I run this, I get the error message " Error saving file c:\ERDNT\SECURITY".

Thanks,
jvin

#4 Jacee

Jacee

    Madam Admin <aka> Maude

  • Admins
  • 27,700 posts
  • Gender:Female


Posted 30 December 2008 - 12:42 AM

Reboot/restart your computer and try Winsockfix again.

MS - MVP Consumer Security 2006 thru 2014


#5 TomGL2

TomGL2

    Advanced Member

  • Advanced Member
  • 3,074 posts
  • Gender:Male


Posted 30 December 2008 - 01:41 AM

Open the Device Manager.  Under View, select Show hidden devices. Expand the category that includes WAN Miniport (PPPOE), usually Network adapters or Non-Plug & Play Drivers.  Right-click WAN Miniport (PPPOE) and click Update Driver.  Select Install from a list, then select Don't search.  Click Next and Finish to reinstall the Windows driver. You may need to restart the computer.

#6 jvin

jvin

    Member

  • Members
  • 19 posts

Posted 30 December 2008 - 06:46 PM

Open the Device Manager. Under View, select Show hidden devices.

Expand the category that includes WAN Miniport (PPPOE), usually Network adapters or Non-Plug & Play Drivers. Right-click WAN Miniport (PPPOE) and click Update Driver. Select Install from a list, then select Don't search. Click Next and Finish to reinstall the Windows driver.

You may need to restart the computer.



I got error.

"A service installation section in this INF is invalid."

Thanks,
jvin

#7 jvin

jvin

    Member

  • Members
  • 19 posts

Posted 30 December 2008 - 07:57 PM

I got error.

"A service installation section in this INF is invalid."

Thanks,
jvin



I tried uninstall again and it worked.
How do I reinstall it again? I don't see it under Device Manager?

Thanks,
jvin

#8 TomGL2

TomGL2

    Advanced Member

  • Advanced Member
  • 3,074 posts
  • Gender:Male


Posted 03 January 2009 - 05:50 AM

I tried uninstall again and it worked.
How do I reinstall it again? I don't see it under Device Manager?

In the Device Manager, click Action, then Scan for hardware changes.  Or, restart the computer.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users